aboutsummaryrefslogtreecommitdiffstats
path: root/g10/exec.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-12 05:18:26 +0000
committerDavid Shaw <[email protected]>2003-02-12 05:18:26 +0000
commit48ac1127aed60ba7f12ef54032cb3a9400ed471a (patch)
treeed72f30d0da9fa8a8c2c69b4dcc4f5e62ccc8e33 /g10/exec.c
parent* Makefile.am: Use a local copy of libexecdir along with @PACKAGE@ as (diff)
downloadgnupg-48ac1127aed60ba7f12ef54032cb3a9400ed471a.tar.gz
gnupg-48ac1127aed60ba7f12ef54032cb3a9400ed471a.zip
* exec.c (set_exec_path): Add debugging line.
* g10.c (print_hex, print_mds): Print long hash strings a lot neater. This assumes at least an 80-character display, as there are a few other similar assumptions here and there. Users who need unformatted hashes can still use with-colons. Check that SHA384 and 512 are available before using them as they are no longer always available.
Diffstat (limited to '')
-rw-r--r--g10/exec.c3
1 files changed, 3 insertions, 0 deletions
diff --git a/g10/exec.c b/g10/exec.c
index 27aa874f0..fd592e853 100644
--- a/g10/exec.c
+++ b/g10/exec.c
@@ -112,6 +112,9 @@ int set_exec_path(const char *path,int method)
strcat(p,path);
+ if(DBG_EXTPROG)
+ log_debug("set_exec_path method %d: %s\n",method,p);
+
/* Notice that path is never freed. That is intentional due to the
way putenv() works. This leaks a few bytes if we call
set_exec_path multiple times. */