aboutsummaryrefslogtreecommitdiffstats
path: root/g10/encode.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-11-01 16:15:45 +0000
committerDavid Shaw <[email protected]>2002-11-01 16:15:45 +0000
commitbdf0e306df1ce86758c4c35d91d3d31019929334 (patch)
tree61890c7d52123f4e51a4955a895465cdda5dfabc /g10/encode.c
parent* Makefile.am: Put gnupg.spec in the root directory so rpm -ta works. (diff)
downloadgnupg-bdf0e306df1ce86758c4c35d91d3d31019929334.tar.gz
gnupg-bdf0e306df1ce86758c4c35d91d3d31019929334.zip
* g10.c (main): Add --no-throw-keyid.
* keydb.h, encode.c (write_pubkey_enc_from_list), g10.c (main), pkclist.c (build_pk_list): Add --hidden-recipient (-R) and --hidden-encrypt-to, which do a single-user variation on --throw-keyid. The "hide this key" flag is carried in bit 0 of the pk_list flags field. * keyserver.c (parse_keyrec): Fix shadowing warning.
Diffstat (limited to '')
-rw-r--r--g10/encode.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/encode.c b/g10/encode.c
index 6727c08ed..b635ce0b4 100644
--- a/g10/encode.c
+++ b/g10/encode.c
@@ -699,7 +699,7 @@ write_pubkey_enc_from_list( PK_LIST pk_list, DEK *dek, IOBUF out )
enc = m_alloc_clear( sizeof *enc );
enc->pubkey_algo = pk->pubkey_algo;
keyid_from_pk( pk, enc->keyid );
- enc->throw_keyid = opt.throw_keyid;
+ enc->throw_keyid = (opt.throw_keyid || (pk_list->flags&1));
if(opt.throw_keyid && (opt.pgp2 || opt.pgp6 || opt.pgp7))
{