aboutsummaryrefslogtreecommitdiffstats
path: root/g10/encode.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-13 09:59:46 +0000
committerWerner Koch <[email protected]>2004-10-13 09:59:46 +0000
commit620ac79ebf8bf6475ed3505b603a4d85a563c314 (patch)
treeaa1a5df7260b166ae3640137188bc153b46a3fe0 /g10/encode.c
parent* Makefile.am (.S.o): Include MPI_SFLAGS. This is our bug 145. (diff)
downloadgnupg-620ac79ebf8bf6475ed3505b603a4d85a563c314.tar.gz
gnupg-620ac79ebf8bf6475ed3505b603a4d85a563c314.zip
* configure.ac: Actually name the option --disable-finger and not
http. * openfile.c (overwrite_filep, make_outfile_name, open_outfile) (open_sigfile): Use iobuf_is_pipe_filename to check for pipes so that special filesnames are taken into account. This is bug 327. * tdbdump.c (import_ownertrust): Ditto. * sign.c (write_plaintext_packet): Ditto. * progress.c (handle_progress): Ditto. * plaintext.c (handle_plaintext): Ditto. * encode.c (encode_simple, encode_crypt): Ditto. * iobuf.c (iobuf_is_pipe_filename): New. * fileutil.c (is_file_compressed): Use it here.
Diffstat (limited to '')
-rw-r--r--g10/encode.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/g10/encode.c b/g10/encode.c
index 29b39975e..1a6ca6da7 100644
--- a/g10/encode.c
+++ b/g10/encode.c
@@ -293,8 +293,8 @@ encode_simple( const char *filename, int mode, int use_seskey )
either partial length or fixed length with the new style
messages. */
- if (filename && *filename && !(*filename == '-' && !filename[1])
- && !opt.textmode ) {
+ if ( !iobuf_is_pipe_filename (filename) && filename && *filename
+ && !opt.textmode ) {
off_t tmpsize;
if ( !(tmpsize = iobuf_get_filelength(inp)) )
@@ -582,7 +582,7 @@ encode_crypt( const char *filename, STRLIST remusr, int use_symkey )
}
}
- if (filename && *filename && !(*filename == '-' && !filename[1])
+ if (!iobuf_is_pipe_filename (filename) && *filename
&& !opt.textmode ) {
off_t tmpsize;