aboutsummaryrefslogtreecommitdiffstats
path: root/g10/cardglue.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-10-25 14:17:24 +0000
committerWerner Koch <[email protected]>2003-10-25 14:17:24 +0000
commitbc45e6e065f080d4cd47cbcecb61195b74293079 (patch)
tree95572974fd3ef83a1fa9c918cb0a3c60af20a336 /g10/cardglue.c
parent* configure.ac (DLLIBS): Work properly on platforms where dlopen and (diff)
downloadgnupg-bc45e6e065f080d4cd47cbcecb61195b74293079.tar.gz
gnupg-bc45e6e065f080d4cd47cbcecb61195b74293079.zip
* g10.c (main) [ENABLE_CARD_SUPPORT]: Add a default for
--pcsc-driver. * cardglue.c (learn_status_cb): Fixed faulty use of !space.
Diffstat (limited to '')
-rw-r--r--g10/cardglue.c10
1 files changed, 5 insertions, 5 deletions
diff --git a/g10/cardglue.c b/g10/cardglue.c
index b258e390f..3173248cb 100644
--- a/g10/cardglue.c
+++ b/g10/cardglue.c
@@ -413,14 +413,14 @@ learn_status_cb (void *opaque, const char *line)
while (spacep (p))
p++;
parm->chv1_cached = atoi (p);
- while (!spacep (p))
+ while (*p && !spacep (p))
p++;
while (spacep (p))
p++;
for (i=0; *p && i < 3; i++)
{
parm->chvmaxlen[i] = atoi (p);
- while (!spacep (p))
+ while (*p && !spacep (p))
p++;
while (spacep (p))
p++;
@@ -428,7 +428,7 @@ learn_status_cb (void *opaque, const char *line)
for (i=0; *p && i < 3; i++)
{
parm->chvretry[i] = atoi (p);
- while (!spacep (p))
+ while (*p && !spacep (p))
p++;
while (spacep (p))
p++;
@@ -439,7 +439,7 @@ learn_status_cb (void *opaque, const char *line)
else if (keywordlen == 7 && !memcmp (keyword, "KEY-FPR", keywordlen))
{
int no = atoi (line);
- while (!spacep (line))
+ while (* line && !spacep (line))
line++;
while (spacep (line))
line++;
@@ -568,7 +568,7 @@ genkey_status_cb (void *opaque, const char *line)
const char *name = line;
char *buf;
- while (!spacep (line))
+ while (*line && !spacep (line))
line++;
while (spacep (line))
line++;