aboutsummaryrefslogtreecommitdiffstats
path: root/g10/card-util.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
committerWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
commit0ebf79c824a0eebff35f757f85608e3dd7750ac3 (patch)
tree915cea6a021349865c78dfb0bed4b327bf4b4202 /g10/card-util.c
parent* g10.c (parse_list_options): Fix non-constant initializer so we can build (diff)
downloadgnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.tar.gz
gnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.zip
* configure.ac: Remove the check for asprintf
* app-common.h (app_openpgp_storekey: Add prototype. * app-openpgp.c (do_sign): Replace asprintf by direct allocation. This avoids problems with missing vasprintf implementations. * card-util.c (generate_card_keys): Add a #warning for gnupg 1.9 and use the same string there. * util.h [!HAVE_VASPRINTF]: Removed prototype. * vasprintf.c: Removed. It was used only at one place and I don't want to get into build problems in 1.4.
Diffstat (limited to '')
-rw-r--r--g10/card-util.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/g10/card-util.c b/g10/card-util.c
index 1d2e47ea2..8cae1dab6 100644
--- a/g10/card-util.c
+++ b/g10/card-util.c
@@ -895,10 +895,10 @@ generate_card_keys (const char *serialno)
m_free(answer);
}
#else
- /* Does 1.9 have answer_is_yes_no_default() ? */
- want_backup = !(cpr_get_answer_is_yes
+ want_backup = cpr_get_answer_is_yes
( "cardedit.genkeys.backup_enc",
- _("Inhibit off-card backup of encryption key? (y/N) ")));
+ _("Make off-card backup of encryption key? (Y/n) "));
+#warning we need answer_is_yes_no_default()
#endif
if ( (info.fpr1valid && !fpr_is_zero (info.fpr1))