aboutsummaryrefslogtreecommitdiffstats
path: root/g10/app-openpgp.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
committerWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
commit0ebf79c824a0eebff35f757f85608e3dd7750ac3 (patch)
tree915cea6a021349865c78dfb0bed4b327bf4b4202 /g10/app-openpgp.c
parent* g10.c (parse_list_options): Fix non-constant initializer so we can build (diff)
downloadgnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.tar.gz
gnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.zip
* configure.ac: Remove the check for asprintf
* app-common.h (app_openpgp_storekey: Add prototype. * app-openpgp.c (do_sign): Replace asprintf by direct allocation. This avoids problems with missing vasprintf implementations. * card-util.c (generate_card_keys): Add a #warning for gnupg 1.9 and use the same string there. * util.h [!HAVE_VASPRINTF]: Removed prototype. * vasprintf.c: Removed. It was used only at one place and I don't want to get into build problems in 1.4.
Diffstat (limited to '')
-rw-r--r--g10/app-openpgp.c7
1 files changed, 6 insertions, 1 deletions
diff --git a/g10/app-openpgp.c b/g10/app-openpgp.c
index d6cbe88a6..11be93e28 100644
--- a/g10/app-openpgp.c
+++ b/g10/app-openpgp.c
@@ -1298,10 +1298,15 @@ do_sign (app_t app, const char *keyidstr, int hashalgo,
{
char *prompt;
- if (asprintf (&prompt, _("PIN [sigs done: %lu]"), sigcount) < 0)
+#define PROMPTSTRING _("PIN [sigs done: %lu]")
+
+ prompt = malloc (strlen (PROMPTSTRING) + 50);
+ if (!prompt)
return gpg_error_from_errno (errno);
+ sprintf (prompt, PROMPTSTRING, sigcount);
rc = pincb (pincb_arg, prompt, &pinvalue);
free (prompt);
+#undef PROMPTSTRING
}
if (rc)
{