aboutsummaryrefslogtreecommitdiffstats
path: root/g10/app-common.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-10-21 18:22:21 +0000
committerWerner Koch <[email protected]>2003-10-21 18:22:21 +0000
commit441aeb85f21436b1ae2ecd1de420138016baba57 (patch)
treefc1c2ed359f38e7700ef53c0872117f571712d4b /g10/app-common.h
parent* configure.ac: Include -ldl when card support is used. (diff)
downloadgnupg-441aeb85f21436b1ae2ecd1de420138016baba57.tar.gz
gnupg-441aeb85f21436b1ae2ecd1de420138016baba57.zip
* passphrase.c (ask_passphrase): Add optional promptid arg.
Changed all callers. * cardglue.c (pin_cb): Use it here, so the machine interface can tell whether the Admin PIN is requested. * cardglue.c (agent_scd_checkpin): New. * misc.c (openpgp_pk_algo_usage): Added AUTH usage. * app-openpgp.c (check_against_given_fingerprint): New. Factored out that code elsewhere. (do_check_pin): New. * card-util.c (card_edit): New command "passwd". Add logic to check the PIN in advance. (card_status): Add new args to return the serial number. Changed all callers.
Diffstat (limited to '')
-rw-r--r--g10/app-common.h6
1 files changed, 6 insertions, 0 deletions
diff --git a/g10/app-common.h b/g10/app-common.h
index 33f23127b..de1e02cac 100644
--- a/g10/app-common.h
+++ b/g10/app-common.h
@@ -65,6 +65,9 @@ struct app_ctx_s {
const char *chvnostr, int reset_mode,
int (*pincb)(void*, const char *, char **),
void *pincb_arg);
+ int (*check_pin) (APP app, const char *keyidstr,
+ int (pincb)(void*, const char *, char **),
+ void *pincb_arg);
} fnc;
@@ -106,6 +109,9 @@ int app_get_challenge (APP app, size_t nbytes, unsigned char *buffer);
int app_change_pin (APP app, CTRL ctrl, const char *chvnostr, int reset_mode,
int (*pincb)(void*, const char *, char **),
void *pincb_arg);
+int app_check_pin (APP app, const char *keyidstr,
+ int (*pincb)(void*, const char *, char **),
+ void *pincb_arg);
/*-- app-openpgp.c --*/