aboutsummaryrefslogtreecommitdiffstats
path: root/g10/app-common.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
committerWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
commit0ebf79c824a0eebff35f757f85608e3dd7750ac3 (patch)
tree915cea6a021349865c78dfb0bed4b327bf4b4202 /g10/app-common.h
parent* g10.c (parse_list_options): Fix non-constant initializer so we can build (diff)
downloadgnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.tar.gz
gnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.zip
* configure.ac: Remove the check for asprintf
* app-common.h (app_openpgp_storekey: Add prototype. * app-openpgp.c (do_sign): Replace asprintf by direct allocation. This avoids problems with missing vasprintf implementations. * card-util.c (generate_card_keys): Add a #warning for gnupg 1.9 and use the same string there. * util.h [!HAVE_VASPRINTF]: Removed prototype. * vasprintf.c: Removed. It was used only at one place and I don't want to get into build problems in 1.4.
Diffstat (limited to '')
-rw-r--r--g10/app-common.h7
1 files changed, 7 insertions, 0 deletions
diff --git a/g10/app-common.h b/g10/app-common.h
index f54f6da92..48bd349f4 100644
--- a/g10/app-common.h
+++ b/g10/app-common.h
@@ -88,6 +88,13 @@ struct app_ctx_s {
#if GNUPG_MAJOR_VERSION == 1
int app_select_openpgp (app_t app);
int app_get_serial_and_stamp (app_t app, char **serial, time_t *stamp);
+int app_openpgp_storekey (app_t app, int keyno,
+ unsigned char *template, size_t template_len,
+ time_t created_at,
+ const unsigned char *m, size_t mlen,
+ const unsigned char *e, size_t elen,
+ int (*pincb)(void*, const char *, char **),
+ void *pincb_arg);
#else
/*-- app-help.c --*/
gpg_error_t app_help_get_keygrip_string (ksba_cert_t cert, char *hexkeygrip);