aboutsummaryrefslogtreecommitdiffstats
path: root/g10/apdu.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-11-06 04:32:54 +0000
committerDavid Shaw <[email protected]>2005-11-06 04:32:54 +0000
commitf48ef0f1f0b9557898d394990fd0342127ab7ea8 (patch)
tree931488b13b5de0fc3f69d9f42656f10377a737ae /g10/apdu.c
parent* libusb.m4: Check for libusb-config and if we find it, use --libs and (diff)
downloadgnupg-f48ef0f1f0b9557898d394990fd0342127ab7ea8.tar.gz
gnupg-f48ef0f1f0b9557898d394990fd0342127ab7ea8.zip
* Makefile.am: Include @LIBUSB_CPPFLAGS@ in our CPPFLAGS. Strictly
speaking this should be only in gpg_CPPFLAGS, but then we have to compile everything twice for gpg and gpgv. * apdu.c (open_pcsc_reader): Fix double free. * gpg.c (main) [__APPLE__]: Default the PCSC driver to the OS X location. Suggested by Patty A. Hardy.
Diffstat (limited to '')
-rw-r--r--g10/apdu.c1
1 files changed, 0 insertions, 1 deletions
diff --git a/g10/apdu.c b/g10/apdu.c
index f59d832d4..5f8c57922 100644
--- a/g10/apdu.c
+++ b/g10/apdu.c
@@ -1603,7 +1603,6 @@ open_pcsc_reader (const char *portstr)
xfree (reader_table[slot].rdrname);
reader_table[slot].rdrname = NULL;
reader_table[slot].used = 0;
- xfree (list);
return -1 /*pcsc_error_to_sw (err)*/;
}