aboutsummaryrefslogtreecommitdiffstats
path: root/g10/apdu.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-10-25 14:17:24 +0000
committerWerner Koch <[email protected]>2003-10-25 14:17:24 +0000
commitbc45e6e065f080d4cd47cbcecb61195b74293079 (patch)
tree95572974fd3ef83a1fa9c918cb0a3c60af20a336 /g10/apdu.c
parent* configure.ac (DLLIBS): Work properly on platforms where dlopen and (diff)
downloadgnupg-bc45e6e065f080d4cd47cbcecb61195b74293079.tar.gz
gnupg-bc45e6e065f080d4cd47cbcecb61195b74293079.zip
* g10.c (main) [ENABLE_CARD_SUPPORT]: Add a default for
--pcsc-driver. * cardglue.c (learn_status_cb): Fixed faulty use of !space.
Diffstat (limited to '')
-rw-r--r--g10/apdu.c5
1 files changed, 3 insertions, 2 deletions
diff --git a/g10/apdu.c b/g10/apdu.c
index f3e332b06..f561677e7 100644
--- a/g10/apdu.c
+++ b/g10/apdu.c
@@ -298,7 +298,8 @@ ct_activate_card (int reader)
{
log_error ("ct_activate_card(%d): activation failed: %s\n",
reader, ct_error_string (rc));
- log_printhex ("buffer:", buf, buflen);
+ if (!rc)
+ log_printhex (" received data:", buf, buflen);
return -1;
}
@@ -972,7 +973,7 @@ apdu_open_reader (const char *portstr)
pcsc_disconnect = dlsym (handle, "SCardDisconnect");
pcsc_status = dlsym (handle, "SCardStatus");
#ifdef _WIN32
- if (pcsc_status)
+ if (!pcsc_status)
pcsc_status = dlsym (handle, "SCardStatusA");
#endif
pcsc_begin_transaction = dlsym (handle, "SCardBeginTransaction");