aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/server.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-12-14 14:36:25 +0000
committerWerner Koch <[email protected]>2016-12-14 14:57:17 +0000
commitd34a2bb410c7c770d26430d69ff77bd83fc407f1 (patch)
tree2d2c193248d105688d6395602130546a4ba2af6d /dirmngr/server.c
parentdirmngr: Implement CERT record lookup via libdns. (diff)
downloadgnupg-d34a2bb410c7c770d26430d69ff77bd83fc407f1.tar.gz
gnupg-d34a2bb410c7c770d26430d69ff77bd83fc407f1.zip
dirmngr: New configure option --disable-libdns.
* configure.ac: Add option --disable-libdns (USE_LIBDNS): New ac_subst and am_conditional. (USE_C99_CFLAGS): Set only if libdns is used. * dirmngr/Makefile.am (dirmngr_SOURCES): Move dns.c and dns.h to ... (dirmngr_SOURCES) [USE_LIBDNS0: here. (t_common_src): Ditto. * dirmngr/dirmngr.c (oRecursiveResolver): New constant. (opts): New option "--recursive-resolver". (parse_rereadable_options): Set option. * dirmngr/t-dns-stuff.c (main): Add option --recursive-resolver. * dirmngr/server.c (cmd_getinfo): Depend output of "dnsinfo" on the new variables. * dirmngr/dns-stuff.c: Include dns.h only if USE_DNSLIB is defined. Also build and call dnslib functions only if USE_DNSLIB is defined. (recursive_resolver): New var. (enable_recursive_resolver): New func. (recursive_resolver_p): New func. -- In case users run into problems building GnuPG, the configure option allows to disable that support and continue w/o Tor support using the system resolver. --recursive-resolver was easy enough to implement and may be useful in some situation. It does not fully work, though. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--dirmngr/server.c6
1 files changed, 6 insertions, 0 deletions
diff --git a/dirmngr/server.c b/dirmngr/server.c
index 3e66868e7..a785238dc 100644
--- a/dirmngr/server.c
+++ b/dirmngr/server.c
@@ -2314,7 +2314,13 @@ cmd_getinfo (assuan_context_t ctx, char *line)
(ctx, "- Forced use of System resolver (w/o Tor support)");
else
{
+#ifdef USE_LIBDNS
+ assuan_set_okay_line (ctx, (recursive_resolver_p ()
+ ? "- Libdns recursive resolver"
+ : "- Libdns stub resolver"));
+#else
assuan_set_okay_line (ctx, "- System resolver (w/o Tor support)");
+#endif
}
err = 0;
}