aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/dns-stuff.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2015-10-22 07:22:41 +0000
committerWerner Koch <[email protected]>2015-10-22 07:22:41 +0000
commit41bb01ae792af78edd28bf1b735cacc0b3ac428a (patch)
treeed764c6b22ac1bee077d3b99bc41bc072ff01c34 /dirmngr/dns-stuff.h
parentdirmngr: Use the new DNS wrapper for the HTTP module. (diff)
downloadgnupg-41bb01ae792af78edd28bf1b735cacc0b3ac428a.tar.gz
gnupg-41bb01ae792af78edd28bf1b735cacc0b3ac428a.zip
Move SRV RR code from common/ to dirmngr/.
* common/srv.c: Merge into dirmngr/dns-stuff.c. Delete file. * common/srv.h: Merge into dirmngr/dns-stuff.h. Delete file. * common/Makefile.am (common_sources): Remove srv.c and srv.h. * g10/keyserver.c: Do not include srv.h. The code using it is anyway disabled. * dirmngr/http.c: Remove header srv.h and stubs. * dirmngr/t-dns-stuff.c: Add option --srv. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--dirmngr/dns-stuff.h15
1 files changed, 15 insertions, 0 deletions
diff --git a/dirmngr/dns-stuff.h b/dirmngr/dns-stuff.h
index 090e79b4d..5ffa0178f 100644
--- a/dirmngr/dns-stuff.h
+++ b/dirmngr/dns-stuff.h
@@ -72,6 +72,20 @@ struct dns_addrinfo_s
+#ifndef MAXDNAME
+#define MAXDNAME 1025
+#endif
+
+struct srventry
+{
+ unsigned short priority;
+ unsigned short weight;
+ unsigned short port;
+ int run_count;
+ char target[MAXDNAME];
+};
+
+
/* Calling this function switches the DNS code into Tor mode if
possibe. Return 0 on success. */
gpg_error_t enable_dns_tormode (void);
@@ -89,6 +103,7 @@ gpg_error_t get_dns_cert (const char *name, int want_certtype,
unsigned char **r_fpr, size_t *r_fprlen,
char **r_url);
+int getsrv (const char *name,struct srventry **list);
#endif /*GNUPG_DIRMNGR_DNS_STUFF_H*/