aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/dns-stuff.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2015-10-21 20:11:59 +0000
committerWerner Koch <[email protected]>2015-10-21 20:11:59 +0000
commit6fafda979df8e7e117f8e6929bcce89513a6e746 (patch)
treeee16beaf501b8b090f9d72b773bf193deac488b1 /dirmngr/dns-stuff.c
parentgpg: Add a new OpenPGP card vendor. (diff)
downloadgnupg-6fafda979df8e7e117f8e6929bcce89513a6e746.tar.gz
gnupg-6fafda979df8e7e117f8e6929bcce89513a6e746.zip
dirmngr: Check that getaddrinfo is available.
* dirmngr/Makefile.am (t_http_SOURCES): Add dns-stuff.c. (t_ldap_parse_uri_SOURCES): Ditto. * dirmngr/dns-stuff.c: Bail out if neither ADNS nor getaddrinfo is available. -- We used to have replacement code for getaddrinfo and thus check for it in configure. However, this was for the old http and dns-cert code from common/. For dirmngr I made liberal use of getaddrinfo w/o without checking. Just in case someone tries to build on an old platform we now error our with a suitable #error. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--dirmngr/dns-stuff.c4
1 files changed, 4 insertions, 0 deletions
diff --git a/dirmngr/dns-stuff.c b/dirmngr/dns-stuff.c
index 00d2b3ee1..3fa6054d3 100644
--- a/dirmngr/dns-stuff.c
+++ b/dirmngr/dns-stuff.c
@@ -46,6 +46,10 @@
# include <adns.h>
#endif
+#if !defined(HAVE_GETADDRINFO) && !defined(USE_ADNS)
+# error Either getaddrinfo or the ADNS libary is required.
+#endif
+
#include "util.h"
#include "host2net.h"
#include "dns-stuff.h"