aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/dirmngr.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2017-11-13 15:09:32 +0000
committerWerner Koch <[email protected]>2017-12-11 10:27:22 +0000
commit6c1dcd79cf0977844179d9a7b189c10af5e42a7e (patch)
treecdc688ad9e52b57e08e5620b808be9f4f406775a /dirmngr/dirmngr.h
parentdoc: Typo fix (diff)
downloadgnupg-6c1dcd79cf0977844179d9a7b189c10af5e42a7e.tar.gz
gnupg-6c1dcd79cf0977844179d9a7b189c10af5e42a7e.zip
dirmngr: Keep track of domains used for WKD queries
* dirmngr/domaininfo.c: New file. * dirmngr/Makefile.am (dirmngr_SOURCES): Add file. * dirmngr/server.c (cmd_wkd_get): Check whether the domain is already known and tell domaininfo about the results. -- This adds a registry for domain information to eventually avoid useless queries for domains which do not support WKD. The missing part is a background task to check whether a queried domain supports WKD at all and to expire old entries. Signed-off-by: Werner Koch <[email protected]> (cherry picked from commit 65038e6852185c20413d8f6602218ee636413b77)
Diffstat (limited to 'dirmngr/dirmngr.h')
-rw-r--r--dirmngr/dirmngr.h12
1 files changed, 12 insertions, 0 deletions
diff --git a/dirmngr/dirmngr.h b/dirmngr/dirmngr.h
index 1f660de10..b08e4fea7 100644
--- a/dirmngr/dirmngr.h
+++ b/dirmngr/dirmngr.h
@@ -17,6 +17,8 @@
*
* You should have received a copy of the GNU General Public License
* along with this program; if not, see <https://www.gnu.org/licenses/>.
+ *
+ * SPDX-License-Identifier: GPL-3.0+
*/
#ifndef DIRMNGR_H
@@ -248,4 +250,14 @@ gpg_error_t gnupg_http_tls_verify_cb (void *opaque,
gpg_error_t dirmngr_load_swdb (ctrl_t ctrl, int force);
+/*-- domaininfo.c --*/
+void domaininfo_print_stats (void);
+int domaininfo_is_wkd_not_supported (const char *domain);
+void domaininfo_set_no_name (const char *domain);
+void domaininfo_set_wkd_supported (const char *domain);
+void domaininfo_set_wkd_not_supported (const char *domain);
+void domaininfo_set_wkd_not_found (const char *domain);
+
+
+
#endif /*DIRMNGR_H*/