aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/dirmngr.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2017-11-13 15:09:32 +0000
committerWerner Koch <[email protected]>2017-12-11 10:27:22 +0000
commit6c1dcd79cf0977844179d9a7b189c10af5e42a7e (patch)
treecdc688ad9e52b57e08e5620b808be9f4f406775a /dirmngr/dirmngr.c
parentdoc: Typo fix (diff)
downloadgnupg-6c1dcd79cf0977844179d9a7b189c10af5e42a7e.tar.gz
gnupg-6c1dcd79cf0977844179d9a7b189c10af5e42a7e.zip
dirmngr: Keep track of domains used for WKD queries
* dirmngr/domaininfo.c: New file. * dirmngr/Makefile.am (dirmngr_SOURCES): Add file. * dirmngr/server.c (cmd_wkd_get): Check whether the domain is already known and tell domaininfo about the results. -- This adds a registry for domain information to eventually avoid useless queries for domains which do not support WKD. The missing part is a background task to check whether a queried domain supports WKD at all and to expire old entries. Signed-off-by: Werner Koch <[email protected]> (cherry picked from commit 65038e6852185c20413d8f6602218ee636413b77)
Diffstat (limited to '')
-rw-r--r--dirmngr/dirmngr.c3
1 files changed, 3 insertions, 0 deletions
diff --git a/dirmngr/dirmngr.c b/dirmngr/dirmngr.c
index 5317c214a..2b64655e8 100644
--- a/dirmngr/dirmngr.c
+++ b/dirmngr/dirmngr.c
@@ -17,6 +17,8 @@
*
* You should have received a copy of the GNU General Public License
* along with this program; if not, see <https://www.gnu.org/licenses/>.
+ *
+ * SPDX-License-Identifier: GPL-3.0+
*/
#include <config.h>
@@ -1871,6 +1873,7 @@ handle_signal (int signo)
case SIGUSR1:
cert_cache_print_stats ();
+ domaininfo_print_stats ();
break;
case SIGUSR2: