aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/dirmngr.c
diff options
context:
space:
mode:
authorBen Kibbey <[email protected]>2016-08-08 22:40:03 +0000
committerJustus Winter <[email protected]>2016-08-09 08:47:46 +0000
commit49829c29e541546084950b8a153067db371d101a (patch)
tree5d2ffb8d53187a25e1fe34e37d7d83ba8111e655 /dirmngr/dirmngr.c
parentagent: SSH support improvement. (diff)
downloadgnupg-49829c29e541546084950b8a153067db371d101a.tar.gz
gnupg-49829c29e541546084950b8a153067db371d101a.zip
Cleanup initialization of libgcrypt.
* common/init.c (init_common_subsystems): Initialize libgcrypt. * dirmngr/Makefile.am (dirmngr_ldap): Link with libgcrypt. -- Most other modules already call gcry_check_version() after init_common_subsystems() so may as well move initialization of libgcrypt to here. Also fixes a warning in the system log from gpgconf --homedir. Signed-off-by: Ben Kibbey <[email protected]>
Diffstat (limited to '')
-rw-r--r--dirmngr/dirmngr.c4
1 files changed, 0 insertions, 4 deletions
diff --git a/dirmngr/dirmngr.c b/dirmngr/dirmngr.c
index 7e629db96..007fa1002 100644
--- a/dirmngr/dirmngr.c
+++ b/dirmngr/dirmngr.c
@@ -755,10 +755,6 @@ main (int argc, char **argv)
/* Check that the libraries are suitable. Do it here because
the option parsing may need services of the libraries. */
-
- if (!gcry_check_version (NEED_LIBGCRYPT_VERSION) )
- log_fatal (_("%s is too old (need %s, have %s)\n"), "libgcrypt",
- NEED_LIBGCRYPT_VERSION, gcry_check_version (NULL) );
if (!ksba_check_version (NEED_KSBA_VERSION) )
log_fatal( _("%s is too old (need %s, have %s)\n"), "libksba",
NEED_KSBA_VERSION, ksba_check_version (NULL) );