aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/Makefile.am
diff options
context:
space:
mode:
authorTobias Fella <[email protected]>2023-11-02 13:34:18 +0000
committerTobias Fella <[email protected]>2023-11-02 13:46:00 +0000
commitb781feb4871d9428d1e6f243f3b72f5aa0844964 (patch)
tree0224d48e1cb19495aa2029f14470cac07dbd5f2f /dirmngr/Makefile.am
parentw32: Use utf8 for the asctimestamp function. (diff)
downloadgnupg-tobias/tsa.tar.gz
gnupg-tobias/tsa.zip
dirmngr: Add timestamp / RFC3161 clienttobias/tsa
* dirmngr/rfc3161.c: Add rfc3161 implementation. * dirmngr/rfc3161.h: Add rfc3161 header. * dirmngr/Makefile.am: Add new file to makefile. * dirmngr/dirmngr.h: Add tsa responder url option. * dirmngr/dirmngr.c: Add tsa responder url option. * dirmngr/server.c: Add assuan call to request a timestamp.
Diffstat (limited to 'dirmngr/Makefile.am')
-rw-r--r--dirmngr/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index a0f8d5a79..4b5b8881e 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -86,7 +86,8 @@ dirmngr_SOURCES = dirmngr.c dirmngr.h server.c crlcache.c crlfetch.c \
dns-stuff.c dns-stuff.h \
http.c http.h http-common.c http-common.h http-ntbtls.c \
ks-action.c ks-action.h ks-engine.h \
- ks-engine-hkp.c ks-engine-http.c ks-engine-finger.c ks-engine-kdns.c
+ ks-engine-hkp.c ks-engine-http.c ks-engine-finger.c ks-engine-kdns.c \
+ rfc3161.c
if USE_LIBDNS
dirmngr_SOURCES += dns.c dns.h