aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2017-08-08 15:28:25 +0000
committerWerner Koch <[email protected]>2017-08-08 15:49:53 +0000
commitfb21aa8b50367e2afa13bad73fc21d6f01a97e18 (patch)
treea448e1a6ef0523166568858669e0e6bb866670a6 /configure.ac
parentgpgscm: Make the test summary stand out (diff)
downloadgnupg-fb21aa8b50367e2afa13bad73fc21d6f01a97e18.tar.gz
gnupg-fb21aa8b50367e2afa13bad73fc21d6f01a97e18.zip
build: New configure option --enable-all-tests.
* configure.ac: New option --enable-all-tests. * tests/gpgscm/ffi.c (ffi_init): New gloabl var *run-all-tests*. * tests/openpgp/all-tests.scm (all-tests): Use that var instead of *maintainer-mode*. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Add --enable-all-tests. -- It is better to have a separate option to run all tests than to put this on top of --enable-maintainer-mode. This way we can also make sure to run all tests during "make distcheck". Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 20a6ed64e..3ff58655c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1668,6 +1668,20 @@ AC_ARG_ENABLE(optimization,
fi])
#
+# Configure option --enable-all-tests
+#
+AC_MSG_CHECKING([whether "make check" shall run all tests])
+AC_ARG_ENABLE(all-tests,
+ AC_HELP_STRING([--enable-all-tests],
+ [let "make check" run all tests]),
+ run_all_tests=$enableval, run_all_tests=no)
+AC_MSG_RESULT($run_all_tests)
+if test "$run_all_tests" = "yes"; then
+ AC_DEFINE(RUN_ALL_TESTS,1,
+ [Defined if "make check" shall run all tests])
+fi
+
+#
# We do not want support for the GNUPG_BUILDDIR environment variable
# in a released version. However, our regression tests suite requires
# this and thus we build with support for it during "make distcheck".