aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2009-06-05 14:11:03 +0000
committerDavid Shaw <[email protected]>2009-06-05 14:11:03 +0000
commit047d97e95e1df831d699fb77cd58c269a13a5c5c (patch)
tree1aba8b3a366cbf6bfe543401009358b079ef3673 /configure.ac
parent* defs.inc: Improved all_cipher_algos and all_hash_algos to work when (diff)
downloadgnupg-047d97e95e1df831d699fb77cd58c269a13a5c5c.tar.gz
gnupg-047d97e95e1df831d699fb77cd58c269a13a5c5c.zip
Add full Camellia support.
* configure.ac: Remove Camellia restriction. * gpg.c (main), misc.c (openpgp_cipher_test_algo): Remove Camellia restriction. * misc.c (map_cipher_openpgp_to_gcry), main.h: Add macros for openpgp_cipher_open, openpgp_cipher_get_algo_keylen, and openpgp_cipher_get_algo_blklen to wrap around the corresponding gcry_* functions, but pass the algorithm number through map_cipher_openpgp_to_gcry. This is needed in case the gcry algorithm number doesn't match the OpenPGP number (c.f. Camellia). * encr-data.c, pubkey-enc.c, mainproc.c, cipher.c, encode.c, seskey.c, passphrase.c, seckey-cert.c: Use new openpgp_cipher_* macros here.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 31a3516e9..6e81812fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,6 @@ have_adns=no
use_bzip2=yes
use_exec=yes
disable_keyserver_path=no
-use_camellia=no
GNUPG_BUILD_PROGRAM(gpg, yes)
@@ -174,22 +173,6 @@ AC_ARG_ENABLE(bzip2,
use_bzip2=$enableval)
AC_MSG_RESULT($use_bzip2)
-# Check whether testing support for Camellia has been requested
-AC_MSG_CHECKING([whether to enable the CAMELLIA cipher for gpg])
-AC_ARG_ENABLE(camellia,
- AC_HELP_STRING([--enable-camellia],[enable the CAMELLIA cipher for gpg]),
- use_camellia=$enableval)
-AC_MSG_RESULT($use_camellia)
-if test x"$use_camellia" = xyes ; then
- AC_DEFINE(USE_CAMELLIA,1,[Define to include the CAMELLIA cipher into gpg])
- AC_MSG_WARN([[
-***
-*** The Camellia cipher for gpg is for testing only and
-*** is NOT for production use!
-***]])
-fi
-
-
# Configure option to allow or disallow execution of external
# programs, like a photo viewer.
AC_MSG_CHECKING([whether to enable external program execution])
@@ -1489,10 +1472,3 @@ echo "
gpg-check-pattern will not be build.
"
fi
-if test x"$use_camellia" = xyes ; then
- echo
- echo "WARNING: The Camellia cipher for gpg is for testing only"
- echo " and is NOT for production use!"
- echo
-fi
-