aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2021-12-17 04:28:42 +0000
committerNIIBE Yutaka <[email protected]>2021-12-17 04:32:14 +0000
commite08225030dfb2090e756d26575f38c371e5a81cf (patch)
tree3b6284bdd8547907a10a6c571112830f99ae0720 /configure.ac
parentgpg: Emit compatible Ed25519 signature. (diff)
downloadgnupg-e08225030dfb2090e756d26575f38c371e5a81cf.tar.gz
gnupg-e08225030dfb2090e756d26575f38c371e5a81cf.zip
w32: Prepare for the case gcrypt.h will not include winsock2.h.
* common/dynload.h: Include specific headers only. * common/exechelp-w32.c: Include <windows.h>. * common/gettime.c: Likewise. * common/utf8conv.c: Likewise. * tests/gpgscm/ffi.c: Likewise. * tools/gpgconf.c: Likewise. * configure.ac: Check winsock2.h, removing gl_HEADER_SYS_SOCKET. -- GnuPG-bug-id: 5731 Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to '')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fea504e74..313b11358 100644
--- a/configure.ac
+++ b/configure.ac
@@ -806,6 +806,7 @@ if test "$have_w32_system" = yes; then
if test "$have_w32ce_system" = yes; then
AC_DEFINE(HAVE_W32CE_SYSTEM,1,[Defined if we run on WindowsCE])
fi
+ AC_CHECK_HEADERS([winsock2.h])
fi
AM_CONDITIONAL(HAVE_W32_SYSTEM, test "$have_w32_system" = yes)
AM_CONDITIONAL(HAVE_W32CE_SYSTEM, test "$have_w32ce_system" = yes)
@@ -1385,7 +1386,6 @@ AC_CHECK_DECLS([sys_siglist],[],[],[#include <signal.h>
])
-gl_HEADER_SYS_SOCKET
gl_TYPE_SOCKLEN_T
AC_SEARCH_LIBS([inet_addr], [nsl])