aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-08-08 19:38:59 +0000
committerDavid Shaw <[email protected]>2002-08-08 19:38:59 +0000
commitfcdd2ec92fda314728056b17f8c0acb3ce5b728e (patch)
treea320eed7d4c7366dc4a744d299302a8f3f6a8aa0 /configure.ac
parent* tdbio.c (tdbio_set_dbname): Create new trustdbs with user-only (diff)
downloadgnupg-fcdd2ec92fda314728056b17f8c0acb3ce5b728e.tar.gz
gnupg-fcdd2ec92fda314728056b17f8c0acb3ce5b728e.zip
* configure.ac: Add an --enable-tiger.
* NEWS: Clarify new permission checks.
Diffstat (limited to '')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b7a4b959..bcc4a41c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,6 +131,16 @@ if test "$use_m_guard" = yes ; then
AC_DEFINE(M_GUARD,1,[Define to use the (obsolete) malloc guarding feature])
fi
+AC_MSG_CHECKING([whether to enable experimental TIGER digest support])
+AC_ARG_ENABLE(tiger,
+ [ --enable-tiger enable experimental TIGER digest support],
+ use_tiger=$enableval, use_tiger=no)
+AC_MSG_RESULT($use_tiger)
+if test "$use_tiger" = yes ; then
+ AC_SUBST(TIGER_O,tiger.o)
+ AC_DEFINE(USE_TIGER,1,[Define to include experimental TIGER digest support])
+fi
+
AC_MSG_CHECKING([whether to enable external program execution])
AC_ARG_ENABLE(exec,
[ --disable-exec disable all external program execution],