aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2005-04-15 01:33:46 +0000
committerMarcus Brinkmann <[email protected]>2005-04-15 01:33:46 +0000
commitf527f721d4d5b10c04267b2a70f7d4e89cc91ea7 (patch)
tree663c14e00b9021d4f45e22a7df802b974ad35439 /configure.ac
parent(retrieve_key_material): Rewritten. Return a (diff)
downloadgnupg-f527f721d4d5b10c04267b2a70f7d4e89cc91ea7.tar.gz
gnupg-f527f721d4d5b10c04267b2a70f7d4e89cc91ea7.zip
2005-04-15 Marcus Brinkmann <[email protected]>
* configure.ac: Add --enable-symcryptrun, disabled by default. Define automake variable BUILD_SYMCRYPTRUN. Check for openpty -lutil, define LIBUTIL_LIBS. tools/ 2005-04-15 Marcus Brinkmann <[email protected]> * Makefile.am: Define symcryptrun make variable depending on BUILD_SYMCRYPTUN. (bin_PROGRAMS): Add ${symcryptrun} instead symcryptrun. (symcryptrun_LDADD): Use $(LIBUTIL_LIBS) instead of -lutil.
Diffstat (limited to '')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7462a759e..34463da04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,7 @@ GNUPG_BUILD_PROGRAM(gpg, yes)
GNUPG_BUILD_PROGRAM(gpgsm, yes)
GNUPG_BUILD_PROGRAM(agent, yes)
GNUPG_BUILD_PROGRAM(scdaemon, yes)
+GNUPG_BUILD_PROGRAM(symcryptrun, no)
AC_SUBST(PACKAGE)
@@ -469,6 +470,16 @@ AC_SUBST(LIBUSB_LIBS)
AC_CHECK_FUNCS(usb_create_match)
#
+# libutil has openpty() and login_tty().
+#
+AC_CHECK_LIB(util, openpty,
+ [ LIBUTIL_LIBS="$LIBUTIL_LIBS -lutil"
+ AC_DEFINE(HAVE_LIBUTIL,1,
+ [defined if libutil is available])
+ ])
+AC_SUBST(LIBUTIL_LIBS)
+
+#
# Check wether it is necessary to link against libdl.
#
LIBS=""
@@ -1046,6 +1057,7 @@ AM_CONDITIONAL(BUILD_GPG, test "$build_gpg" = "yes")
AM_CONDITIONAL(BUILD_GPGSM, test "$build_gpgsm" = "yes")
AM_CONDITIONAL(BUILD_AGENT, test "$build_agent" = "yes")
AM_CONDITIONAL(BUILD_SCDAEMON, test "$build_scdaemon" = "yes")
+AM_CONDITIONAL(BUILD_SYMCRYPTRUN, test "$build_symcryptrun" = "yes")