aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-07-10 15:03:55 +0000
committerDavid Shaw <[email protected]>2003-07-10 15:03:55 +0000
commita88cb47d5536022dda5f856e213de2df9c41f344 (patch)
tree441367a8cafd8c3ce94ac829154d2a6d09967a78 /configure.ac
parent* parse-packet.c (parse_signature): No need to reserve 8 bytes for the (diff)
downloadgnupg-a88cb47d5536022dda5f856e213de2df9c41f344.tar.gz
gnupg-a88cb47d5536022dda5f856e213de2df9c41f344.zip
* configure.ac: configure.ac: Check for sigset_t and struct sigaction.
This is for Forte c89 on Solaris which seems to define only the function call half of the two pairs by default.
Diffstat (limited to '')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5ee47cea7..b0191b2cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -734,8 +734,12 @@ AC_CHECK_FUNCS(memmove gettimeofday getrusage setrlimit clock_gettime)
AC_CHECK_FUNCS(atexit raise getpagesize strftime nl_langinfo setlocale)
AC_CHECK_FUNCS(waitpid wait4 sigaction sigprocmask rand pipe stat)
AC_REPLACE_FUNCS(mkdtemp)
+AC_CHECK_TYPES([struct sigaction, sigset_t],,,[#include <signal.h>])
+
+# See if getopt is in libiberty. This is of course not optimal since
+# it might be somewhere other than libiberty, but does cover the
+# mingw32 case.
-dnl see if getopt is in libiberty
AC_CHECK_FUNC(getopt,,AC_CHECK_LIB(iberty,getopt,AC_SUBST(GETOPT,"-liberty")))
#