aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-07-28 18:59:36 +0000
committerWerner Koch <[email protected]>2005-07-28 18:59:36 +0000
commit986a137c58cae8dc7210ccf51cdea38ec6e8828f (patch)
tree4f847f04509fc74a1fa6db4839abd5d41c80eb9c /configure.ac
parentConverted all m_free to xfree etc. (diff)
downloadgnupg-986a137c58cae8dc7210ccf51cdea38ec6e8828f.tar.gz
gnupg-986a137c58cae8dc7210ccf51cdea38ec6e8828f.zip
Implemented PKA trust model
Diffstat (limited to '')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 107983826..33a9e09f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -563,7 +563,8 @@ AC_CHECK_FUNC(gethostbyname, , AC_CHECK_LIB(nsl, gethostbyname,
AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt,
[NETLIBS="-lsocket $NETLIBS"]))
-dnl Now try for the resolver functions so we can use DNS SRV
+dnl Now try for the resolver functions so we can use DNS SRV and our
+dnl PKA feature.
AC_ARG_ENABLE(dns-srv,
AC_HELP_STRING([--disable-dns-srv],
@@ -597,6 +598,7 @@ if (test x"$try_hkp" = xyes || test x"$try_http" = xyes) && test x"$use_dns_srv"
if test x"$use_dns_srv" = xyes ; then
AC_DEFINE(USE_DNS_SRV,1,[define to use DNS SRV])
SRVLIBS=$LIBS
+ AC_DEFINE(USE_DNS_PKA,1,[define to use our experimental DNS PKA])
fi
LIBS=$_srv_save_libs