aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-03-12 18:33:30 +0000
committerWerner Koch <[email protected]>2014-03-14 11:36:36 +0000
commit5d321eb00be0774418de1a05678ac0ec44d7193b (patch)
tree6a794d25d31daba2681fec6bb421e1f615e0b88b /configure.ac
parentgpg: Add option --dirmngr-program. (diff)
downloadgnupg-5d321eb00be0774418de1a05678ac0ec44d7193b.tar.gz
gnupg-5d321eb00be0774418de1a05678ac0ec44d7193b.zip
dirmngr: Default to a user socket name and enable autostart.
* common/homedir.c (dirmngr_socket_name): Rename to dirmngr_sys_socket_name. (dirmngr_user_socket_name): New. * common/asshelp.c (start_new_dirmngr): Handle sys and user dirmngr socket. * dirmngr/dirmngr.c (main): Ditto. * dirmngr/server.c (cmd_getinfo): Ditto. * sm/server.c (gpgsm_server): Ditto. * dirmngr/dirmngr-client.c (start_dirmngr): Likewise. * tools/gpgconf.c (main): Print "dirmngr-sys-socket" with --list-dirs. * configure.ac (USE_DIRMNGR_AUTO_START): Set by default.
Diffstat (limited to '')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index c20984afd..e384fba2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,7 +92,7 @@ disable_keyserver_path=no
card_support=yes
use_ccid_driver=yes
use_standard_socket=yes
-dirmngr_auto_start=no
+dirmngr_auto_start=yes
try_ks_ldap=no
@@ -428,15 +428,10 @@ AC_ARG_ENABLE(ccid-driver,
use_ccid_driver=$enableval)
AC_MSG_RESULT($use_ccid_driver)
-#
-# Dirmngr is nowadays a system service and thus it usually does no
-# make sense to start it as needed. However on some systems this is
-# possible; this option enable the feature.
-#
AC_MSG_CHECKING([whether to auto start dirmngr])
AC_ARG_ENABLE(dirmngr-auto-start,
- AC_HELP_STRING([--enable-dirmngr-auto-start],
- [enable auto starting of the dirmngr]),
+ AC_HELP_STRING([--disable-dirmngr-auto-start],
+ [disable auto starting of the dirmngr]),
dirmngr_auto_start=$enableval)
AC_MSG_RESULT($dirmngr_auto_start)
if test "$dirmngr_auto_start" = yes ; then