aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-10-11 22:13:49 +0000
committerDavid Shaw <[email protected]>2005-10-11 22:13:49 +0000
commit47433adaa56339dbc28c60b9f800fe1522312ad2 (patch)
treef27b972c447a3284f9f23c5c920e0d8d2736ce11 /configure.ac
parentYet another fix for the gpg.c rename (diff)
downloadgnupg-47433adaa56339dbc28c60b9f800fe1522312ad2.tar.gz
gnupg-47433adaa56339dbc28c60b9f800fe1522312ad2.zip
* getkey.c (merge_selfsigs_subkey), sig-check.c (signature_check2),
keygen.c (make_backsig): Did some backsig interop testing with the PGP folks. All is well, so I'm turning generation of backsigs on for new keys. Checking for backsigs on verification is still off.
Diffstat (limited to '')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 484c1a913..d77d4eaca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,10 +129,10 @@ AC_ARG_ENABLE(gnupg-iconv,
gnupg_use_iconv=$enableval, gnupg_use_iconv=yes)
AC_MSG_RESULT($gnupg_use_iconv)
-AC_MSG_CHECKING([whether to enable the experimental backsigs code])
+AC_MSG_CHECKING([whether to require signing subkeys to have back signatures])
AC_ARG_ENABLE(backsigs,
AC_HELP_STRING([--enable-backsigs],
- [enable the experimental backsigs code]),
+ [require signing subkeys to have back signatures]),
do_backsigs=$enableval, do_backsigs=no)
AC_MSG_RESULT($do_backsigs)
@@ -757,8 +757,8 @@ if test "$gnupg_use_iconv" = yes ; then
AC_DEFINE(USE_GNUPG_ICONV,1,[Define to use the new iconv based code])
fi
-if test "$do_backsigs" = yes ; then
- AC_DEFINE(DO_BACKSIGS,1,[Define to enable the experimental backsigs code])
+if test "$do_backsigs" = no ; then
+ AC_DEFINE(FAKE_BACKSIGS,1,[Define to fake missing backsigs])
fi
AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes)