aboutsummaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2006-10-10 11:11:04 +0000
committerWerner Koch <[email protected]>2006-10-10 11:11:04 +0000
commit2e8481c03bceef8d009ea30b40c3e1674cfc9e93 (patch)
tree03469588ff8e79f7c2cc28300cc133c9e89c69d1 /common
parentMake it also work for the card. (diff)
downloadgnupg-2e8481c03bceef8d009ea30b40c3e1674cfc9e93.tar.gz
gnupg-2e8481c03bceef8d009ea30b40c3e1674cfc9e93.zip
Various changes
Diffstat (limited to '')
-rw-r--r--common/ChangeLog11
-rw-r--r--common/Makefile.am2
-rw-r--r--common/gpgrlhelp.c6
-rw-r--r--common/util.h7
4 files changed, 24 insertions, 2 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index 12d42ae82..f5cae13e8 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,14 @@
+2006-10-08 Werner Koch <[email protected]>
+
+ * gpgrlhelp.c: Trun all functions into dummies if readline is not
+ available.
+
+2006-10-06 Werner Koch <[email protected]>
+
+ * Makefile.am (AM_CFLAGS): Use PTH version of libassuan.
+
+ * util.h (GNUPG_GCC_A_SENTINEL): Defined for gcc >= 4.
+
2006-10-04 David Shaw <[email protected]>
* gpgrlhelp.c: readline requires stdio.h.
diff --git a/common/Makefile.am b/common/Makefile.am
index 52b56e94c..64c7f10d1 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -26,7 +26,7 @@ TESTS = $(module_tests)
AM_CPPFLAGS = -I$(top_srcdir)/gl
-AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(KSBA_CFLAGS) \
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_PTH_CFLAGS) $(KSBA_CFLAGS) \
$(PTH_CFLAGS)
libcommon_a_SOURCES = \
diff --git a/common/gpgrlhelp.c b/common/gpgrlhelp.c
index 56a9ce28c..ec72c98c8 100644
--- a/common/gpgrlhelp.c
+++ b/common/gpgrlhelp.c
@@ -40,6 +40,7 @@
#include "common-defs.h"
+#ifdef HAVE_LIBREADLINE
static void
set_completer (rl_completion_func_t *completer)
{
@@ -68,12 +69,15 @@ init_stream (FILE *fp)
rl_inhibit_completion = 1;
}
+#endif /*HAVE_LIBREADLINE*/
+
/* Initialize our readline code. This should be called as early as
possible as it is actually a constructur. */
void
gnupg_rl_initialize (void)
{
+#ifdef HAVE_LIBREADLINE
tty_private_set_rl_hooks (init_stream,
set_completer,
inhibit_completion,
@@ -81,7 +85,7 @@ gnupg_rl_initialize (void)
readline,
add_history);
rl_readline_name = "GnuPG";
-
+#endif
}
diff --git a/common/util.h b/common/util.h
index 8940c9355..7a9738d69 100644
--- a/common/util.h
+++ b/common/util.h
@@ -43,6 +43,13 @@
#include "../jnlib/dotlock.h"
#include "../jnlib/utf8conv.h"
+#if __GNUC__ >= 4
+# define GNUPG_GCC_A_SENTINEL(a) __attribute__ ((sentinel(a)))
+#else
+# define GNUPG_GCC_A_SENTINEL(a)
+#endif
+
+
/* We need this type even if we are not using libreadline and or we
did not include libreadline in the current file. */
#ifndef GNUPG_LIBREADLINE_H_INCLUDED