aboutsummaryrefslogtreecommitdiffstats
path: root/common/ttyname.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-06-01 15:46:01 +0000
committerWerner Koch <[email protected]>2005-06-01 15:46:01 +0000
commitcad9562436e61cdaf1a2f03ba96bcc82077205e6 (patch)
tree6db1dde6998d0ad1ae13a4581f66cace736a2399 /common/ttyname.c
parent* agent.h (out_of_core): s/__inline__/inine. Noted by Ray Link. (diff)
downloadgnupg-cad9562436e61cdaf1a2f03ba96bcc82077205e6.tar.gz
gnupg-cad9562436e61cdaf1a2f03ba96bcc82077205e6.zip
* configure.ac (gl_INIT): Add gnulib stuff.
(fseeko, ftello, ttyname, isascii): Replaced the AC_REPLACE_FUNCS by a simple check. (putc_unlocked): Removed check. Not used. (strsep, mkdtemp, asprintf): Replaced checks by gnulib checks. (xsize): Added will probably come handy soon. (CFLAGS): Use -Wformat-security instead of -Wformat-nonliteral. Add --Wno-format-y2k. * gl/, gl/m4/: New. * gpg-agent.c: Include setenv.h. * Makefile.am (AM_CPPFLAGS): Added. * util.h: Add some includes for gnulib. (ttyname, isascii): Define them inline. * fseeko.c, ftello.c: Removed. * strsep.c, mkdtemp.c: Removed. * ttyname.c, isascii.c: Removed. * mkdtemp.c: Removed. * exec.c: Include mkdtemp.h * keybox-file.c (ftello) [!HAVE_FSEEKO]: New replacement function. Copied from ../common/ftello.c. * keybox-update.c (fseeko) [!HAVE_FSEEKO]: New replacement function. Copied from ../common/iobuf.c. * scdaemon.c: Include mkdtemp.h. * misc.c: Include setenv.h. * symcryptrun.c: Include mkdtemp.h.
Diffstat (limited to 'common/ttyname.c')
-rw-r--r--common/ttyname.c32
1 files changed, 0 insertions, 32 deletions
diff --git a/common/ttyname.c b/common/ttyname.c
deleted file mode 100644
index 822beef99..000000000
--- a/common/ttyname.c
+++ /dev/null
@@ -1,32 +0,0 @@
-/* ttyname.c - Replacement for ttyname.
- * Copyright (C) 2004 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-/* This one is a simple dummy and suitable for Dosish systems. */
-
-#ifdef HAVE_CONFIG_H
-#include <config.h>
-#endif
-#include <stdio.h>
-
-char *
-ttyname (int fd)
-{
- return NULL;
-}