aboutsummaryrefslogtreecommitdiffstats
path: root/common/sysutils.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-05-02 06:06:10 +0000
committerWerner Koch <[email protected]>2014-05-02 06:22:38 +0000
commit84289e85c72ae58c321dfdb96816700a6b7f7122 (patch)
treeb5df413e25fd8e72702e23a4efc36813475d5075 /common/sysutils.c
parentestream: Implement "samethread" mode keyword. (diff)
downloadgnupg-84289e85c72ae58c321dfdb96816700a6b7f7122.tar.gz
gnupg-84289e85c72ae58c321dfdb96816700a6b7f7122.zip
common: Cleanup the use of USE_NPTH and HAVE_NPTH macros.
* configure.ac (HAVE_NPTH): New ac_define. * common/estream.c: Use USE_NPTH instead of HAVE_NPTH. * common/http.c: Ditto. Replace remaining calls to pth by npth calls. (connect_server): Remove useless _(). * common/exechelp-posix.c, common/exechelp-w32.c * common/exechelp-w32ce.c: Use HAVE_PTH to include npth.h. * common/init.c (_init_common_subsystems): Remove call to pth_init. * common/sysutils.c (gnupg_sleep): Use npth_sleep. * scd/ccid-driver.c (my_sleep): Ditto. -- USE_NPTH is used in case were we may build with and without nPth. The missing definition HAVE_NPTH didn't allowed us to build outher sources with nPTh support.
Diffstat (limited to 'common/sysutils.c')
-rw-r--r--common/sysutils.c14
1 files changed, 2 insertions, 12 deletions
diff --git a/common/sysutils.c b/common/sysutils.c
index 95e0f8c0b..afb12edfd 100644
--- a/common/sysutils.c
+++ b/common/sysutils.c
@@ -275,18 +275,8 @@ check_permissions(const char *path,int extension,int checkonly)
void
gnupg_sleep (unsigned int seconds)
{
-#ifdef HAVE_NPTH
- /* With Pth we force a regular sleep for seconds == 0 so that also
- the process will give up its timeslot. */
- if (!seconds)
- {
-# ifdef HAVE_W32_SYSTEM
- Sleep (0);
-# else
- sleep (0);
-# endif
- }
- pth_sleep (seconds);
+#ifdef USE_NPTH
+ npth_sleep (seconds);
#else
/* Fixme: make sure that a sleep won't wake up to early. */
# ifdef HAVE_W32_SYSTEM