aboutsummaryrefslogtreecommitdiffstats
path: root/common/stringhelp.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-11-11 14:14:31 +0000
committerWerner Koch <[email protected]>2014-11-11 14:14:31 +0000
commitb8cdfac353ad96d4ef025c066c16dbde34805661 (patch)
treef26e4c6589c0dfc0bb8ff25b645262eb05d24677 /common/stringhelp.h
parentRemove use of gnulib (part 1) (diff)
downloadgnupg-b8cdfac353ad96d4ef025c066c16dbde34805661.tar.gz
gnupg-b8cdfac353ad96d4ef025c066c16dbde34805661.zip
Remove use of gnulib (part 2)
* configure.ac (strpbrk): Add to AC_CHECK_FUNCS. (gl_EARLY): Remove. * common/stringhelp.c (strpbrk) [!HAVE_STRPBRK]: New. * common/sysutils.c (gnupg_mkdtemp): New. Based on code from glibc-2.6. (gnupg_setenv): Rewrite. (gnupg_unsetenv): Rewrite. * g10/exec.c: Include sysutils.h and replace mkdtemp by gnupg_mkdtemp. * g13/be-encfs.c: Ditto. * g13/mount.c: Ditto. * tools/symcryptrun.c (confucius_mktmpdir): Ditto. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'common/stringhelp.h')
-rw-r--r--common/stringhelp.h3
1 files changed, 3 insertions, 0 deletions
diff --git a/common/stringhelp.h b/common/stringhelp.h
index 1ad380e79..1d3ee7237 100644
--- a/common/stringhelp.h
+++ b/common/stringhelp.h
@@ -99,6 +99,9 @@ int memicmp( const char *a, const char *b, size_t n );
#ifndef HAVE_STPCPY
char *stpcpy(char *a,const char *b);
#endif
+#ifndef HAVE_STRPBRK
+char *strpbrk (const char *s, const char *accept);
+#endif
#ifndef HAVE_STRSEP
char *strsep (char **stringp, const char *delim);
#endif