aboutsummaryrefslogtreecommitdiffstats
path: root/common/simple-pwquery.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-12-21 19:05:15 +0000
committerWerner Koch <[email protected]>2004-12-21 19:05:15 +0000
commit01f3f2515834876e2131d077e34c3cae4f9a2dc0 (patch)
tree6033e9b66eb3aa8cb46c8fa88cdf80ac29923dba /common/simple-pwquery.h
parent* homedir.c: New. Use CSIDL_APPDATA for W32 as the default home (diff)
downloadgnupg-01f3f2515834876e2131d077e34c3cae4f9a2dc0.tar.gz
gnupg-01f3f2515834876e2131d077e34c3cae4f9a2dc0.zip
* preset-passphrase.c (preset_passphrase): Handle --passphrase.
* Makefile.am (gpg_preset_passphrase_LDADD): Reorder libs so that pwquery may use stuff from jnlib. Conditionally add -lwsock2 (gpg_protect_tool_LDADD): Ditto. * preset-passphrase.c (main): Use default_homedir(). (main) [W32]: Initialize sockets. * simple-pwquery.c (agent_open) [W32]: Implement for W32. (readline) [W32]: Use recv instead of read. (writen) [W32]: Use send instead of write. (my_stpcpy): Define a stpcpy replacement so that this file continues to be self-contained. (agent_send_all_options) [W32]: Don't call ttyname. * gnupg-badge-openpgp.eps, gnupg-badge-openpgp.jpg: New * gnupg.texi: Add a logo. * sysnotes.texi: New. * gpgsm.c (main): Use default_homedir(). (main) [W32]: Default to disabled CRL checks. * gpgconf-comp.c (get_config_pathname) [DOSISH]: Detect absolute pathnames with a drive letter.
Diffstat (limited to '')
-rw-r--r--common/simple-pwquery.h3
1 files changed, 3 insertions, 0 deletions
diff --git a/common/simple-pwquery.h b/common/simple-pwquery.h
index 5947c42b5..c7ebf9401 100644
--- a/common/simple-pwquery.h
+++ b/common/simple-pwquery.h
@@ -57,6 +57,9 @@ char *simple_pwquery (const char *cacheid,
const char *description,
int *errorcode);
+/* Perform the simple query QUERY (which must be new-line and 0
+ terminated) and return the error code. */
+int simple_query (const char *query);
#define SPWQ_OUT_OF_CORE 1
#define SPWQ_IO_ERROR 2