aboutsummaryrefslogtreecommitdiffstats
path: root/common/name-value.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-06-23 09:55:46 +0000
committerWerner Koch <[email protected]>2016-06-23 09:55:46 +0000
commitb841a883a2a66807aa427e65d49067584bedfbe2 (patch)
treeae9ece6c71b2753d25c870fcdd977e5a1c59b478 /common/name-value.h
parentcommon: Change license of b64dec.c and b64enc.c to LGPLv2.1+ (diff)
downloadgnupg-b841a883a2a66807aa427e65d49067584bedfbe2.tar.gz
gnupg-b841a883a2a66807aa427e65d49067584bedfbe2.zip
common: Rename private-keys.c to name-value.c
* common/private-keys.c: Rename to name-value.c. * common/private-keys.h: Rename to name-value.h. Chage all users. * common/t-private-keys.c: Rename to t-name-value.c. * common/Makefile.am: Adjust accordingly. -- The module is cool enough to be used for other purposes as well. Thus we better change the name. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--common/name-value.h (renamed from common/private-keys.h)8
1 files changed, 4 insertions, 4 deletions
diff --git a/common/private-keys.h b/common/name-value.h
index d21e94f7c..0a8694a57 100644
--- a/common/private-keys.h
+++ b/common/name-value.h
@@ -1,4 +1,4 @@
-/* private-keys.h - Parser and writer for the extended private key format.
+/* name-value.h - Parser and writer for a name-value format.
* Copyright (C) 2016 g10 Code GmbH
*
* This file is part of GnuPG.
@@ -27,8 +27,8 @@
* along with this program; if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef GNUPG_COMMON_PRIVATE_KEYS_H
-#define GNUPG_COMMON_PRIVATE_KEYS_H
+#ifndef GNUPG_COMMON_NAME_VALUE_H
+#define GNUPG_COMMON_NAME_VALUE_H
struct private_key_container;
typedef struct private_key_container *pkc_t;
@@ -106,4 +106,4 @@ gpg_error_t pkc_parse (pkc_t *result, int *errlinep, estream_t stream);
/* Write a representation of PK to STREAM. */
gpg_error_t pkc_write (pkc_t pk, estream_t stream);
-#endif /* GNUPG_COMMON_PRIVATE_KEYS_H */
+#endif /* GNUPG_COMMON_NAME_VALUE_H */