aboutsummaryrefslogtreecommitdiffstats
path: root/common/name-value.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-06-23 09:55:46 +0000
committerWerner Koch <[email protected]>2016-06-23 09:55:46 +0000
commitb841a883a2a66807aa427e65d49067584bedfbe2 (patch)
treeae9ece6c71b2753d25c870fcdd977e5a1c59b478 /common/name-value.c
parentcommon: Change license of b64dec.c and b64enc.c to LGPLv2.1+ (diff)
downloadgnupg-b841a883a2a66807aa427e65d49067584bedfbe2.tar.gz
gnupg-b841a883a2a66807aa427e65d49067584bedfbe2.zip
common: Rename private-keys.c to name-value.c
* common/private-keys.c: Rename to name-value.c. * common/private-keys.h: Rename to name-value.h. Chage all users. * common/t-private-keys.c: Rename to t-name-value.c. * common/Makefile.am: Adjust accordingly. -- The module is cool enough to be used for other purposes as well. Thus we better change the name. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--common/name-value.c (renamed from common/private-keys.c)9
1 files changed, 7 insertions, 2 deletions
diff --git a/common/private-keys.c b/common/name-value.c
index 4cf7d227c..601ddd43b 100644
--- a/common/private-keys.c
+++ b/common/name-value.c
@@ -1,4 +1,4 @@
-/* private-keys.c - Parser and writer for the extended private key format.
+/* name-value.c - Parser and writer for a name-value format.
* Copyright (C) 2016 g10 Code GmbH
*
* This file is part of GnuPG.
@@ -27,16 +27,21 @@
* along with this program; if not, see <http://www.gnu.org/licenses/>.
*/
+/*
+ * This module aso provides features for the extended private key
+ * format of gpg-agent.
+ */
+
#include <config.h>
#include <assert.h>
#include <gcrypt.h>
#include <gpg-error.h>
#include <string.h>
-#include "private-keys.h"
#include "mischelp.h"
#include "strlist.h"
#include "util.h"
+#include "name-value.h"
struct private_key_container
{