aboutsummaryrefslogtreecommitdiffstats
path: root/common/mkdtemp.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-12-20 16:17:25 +0000
committerWerner Koch <[email protected]>2004-12-20 16:17:25 +0000
commit581f5ddb1724f469dc7f934f5093179dfb1e05a9 (patch)
treed239f17e59f705f1b85c5cb5c2b9e1595e512e5f /common/mkdtemp.c
parent(do_pth_event_free): The events are hold in a ring (diff)
downloadgnupg-581f5ddb1724f469dc7f934f5093179dfb1e05a9.tar.gz
gnupg-581f5ddb1724f469dc7f934f5093179dfb1e05a9.zip
* configure.ac: Add PATHSEP_C and PATHSEP_S. For W32 let all
directories default to c:/gnupg. Require libassuan 0.6.9. * gpg-agent.c (main) [W32]: Now that Mutexes work we can remove the pth_init kludge. (main): Add new options --[no-]use-standard-socket. (check_for_running_agent): Check whether it is running on the standard socket. * sysutils.h [W32]: Define sleep. * util.h: Add prototype for mkdtemp. * call-agent.c (start_agent): Before starting a pipe server start to connect to a server on the standard socket. Use PATHSEP * call-dirmngr.c (start_dirmngr): Use PATHSEP. * import.c: Include unistd.h for dup and close.
Diffstat (limited to '')
-rw-r--r--common/mkdtemp.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/common/mkdtemp.c b/common/mkdtemp.c
index abe731e0a..a85b89eb4 100644
--- a/common/mkdtemp.c
+++ b/common/mkdtemp.c
@@ -35,7 +35,8 @@
# define mkdir(a,b) mkdir(a)
#endif
-char *mkdtemp(char *template)
+char *
+mkdtemp (char *template)
{
int attempts,idx,count=0;
unsigned char *ch;