aboutsummaryrefslogtreecommitdiffstats
path: root/common/logging.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-01-08 10:47:07 +0000
committerWerner Koch <[email protected]>2014-01-08 10:47:07 +0000
commit75ba215ebd8be7e14b26bb53ef3c7d41e4ce1e02 (patch)
tree3e3f63f0e8e680db32b261ea91091de7499cd96e /common/logging.c
parentgpg: Change --show-session-key to print the session key earlier. (diff)
downloadgnupg-75ba215ebd8be7e14b26bb53ef3c7d41e4ce1e02.tar.gz
gnupg-75ba215ebd8be7e14b26bb53ef3c7d41e4ce1e02.zip
w32: Add macro for the registry key.
* configure.ac (GNUPG_REGISTRY_DIR) [W32]: New ac-define. * common/homedir.c (default_homedir): Use it. * common/logging.c (do_logv): Use it.
Diffstat (limited to 'common/logging.c')
-rw-r--r--common/logging.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/common/logging.c b/common/logging.c
index e94cdaf3e..2b5bb2db1 100644
--- a/common/logging.c
+++ b/common/logging.c
@@ -636,7 +636,7 @@ do_logv (int level, int ignore_arg_ptr, const char *fmt, va_list arg_ptr)
tmp = (no_registry
? NULL
- : read_w32_registry_string (NULL, "Software\\GNU\\"GNUPG_NAME,
+ : read_w32_registry_string (NULL, GNUPG_REGISTRY_DIR,
"DefaultLogFile"));
log_set_file (tmp && *tmp? tmp : NULL);
jnlib_free (tmp);