aboutsummaryrefslogtreecommitdiffstats
path: root/common/iobuf.c
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2010-06-08 18:33:21 +0000
committerMarcus Brinkmann <[email protected]>2010-06-08 18:33:21 +0000
commit70f3a9bbb611f9d2359a4a52346605a9a367fbf2 (patch)
tree7f08734d190c000c6b53cad1395f323aa8e66cfe /common/iobuf.c
parentW32CE fix. (diff)
downloadgnupg-70f3a9bbb611f9d2359a4a52346605a9a367fbf2.tar.gz
gnupg-70f3a9bbb611f9d2359a4a52346605a9a367fbf2.zip
2010-06-08 Marcus Brinkmann <[email protected]>
* Makefile.am (AM_CFLAGS): Add $(LIBASSUAN_CFLAGS). (t_common_ldadd): Add $(LIBASSUAN_LIBS). * sysutils.c: Include <assuan.h>. (translate_sys2libc_fd_int): Cast to silence gcc warning. * iobuf.c: Include <assuan.h> (translate_file_handle): Fix syntax error.
Diffstat (limited to 'common/iobuf.c')
-rw-r--r--common/iobuf.c6
1 files changed, 4 insertions, 2 deletions
diff --git a/common/iobuf.c b/common/iobuf.c
index 20649bda1..b9bed3218 100644
--- a/common/iobuf.c
+++ b/common/iobuf.c
@@ -37,6 +37,8 @@
# include <swis.h>
#endif /* __riscos__ */
+#include <assuan.h>
+
#include "util.h"
#include "sysutils.h"
#include "iobuf.h"
@@ -2366,11 +2368,11 @@ iobuf_read_line (iobuf_t a, byte ** addr_of_buffer,
static int
translate_file_handle (int fd, int for_write)
{
-#if defined (HAVE_W32CE_SYSTEM)
+#if defined(HAVE_W32CE_SYSTEM)
/* This is called only with one of the special filenames. Under
W32CE the FD here is not a file descriptor but a rendezvous id,
thus we need to finish the pipe first. */
- fd = _assuan_w32ce_finish_pipe fd, for_write);
+ fd = _assuan_w32ce_finish_pipe (fd, for_write);
#elif defined(HAVE_W32_SYSTEM)
{
int x;