aboutsummaryrefslogtreecommitdiffstats
path: root/common/init.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-05-02 06:06:10 +0000
committerWerner Koch <[email protected]>2014-05-02 06:22:38 +0000
commit84289e85c72ae58c321dfdb96816700a6b7f7122 (patch)
treeb5df413e25fd8e72702e23a4efc36813475d5075 /common/init.c
parentestream: Implement "samethread" mode keyword. (diff)
downloadgnupg-84289e85c72ae58c321dfdb96816700a6b7f7122.tar.gz
gnupg-84289e85c72ae58c321dfdb96816700a6b7f7122.zip
common: Cleanup the use of USE_NPTH and HAVE_NPTH macros.
* configure.ac (HAVE_NPTH): New ac_define. * common/estream.c: Use USE_NPTH instead of HAVE_NPTH. * common/http.c: Ditto. Replace remaining calls to pth by npth calls. (connect_server): Remove useless _(). * common/exechelp-posix.c, common/exechelp-w32.c * common/exechelp-w32ce.c: Use HAVE_PTH to include npth.h. * common/init.c (_init_common_subsystems): Remove call to pth_init. * common/sysutils.c (gnupg_sleep): Use npth_sleep. * scd/ccid-driver.c (my_sleep): Ditto. -- USE_NPTH is used in case were we may build with and without nPth. The missing definition HAVE_NPTH didn't allowed us to build outher sources with nPTh support.
Diffstat (limited to 'common/init.c')
-rw-r--r--common/init.c8
1 files changed, 1 insertions, 7 deletions
diff --git a/common/init.c b/common/init.c
index 35e623fc2..91ee912bb 100644
--- a/common/init.c
+++ b/common/init.c
@@ -156,18 +156,12 @@ _init_common_subsystems (gpg_err_source_t errsource, int *argcp, char ***argvp)
#ifdef HAVE_W32_SYSTEM
/* For W32 we need to initialize the socket layer. This is because
we use recv and send in libassuan as well as at some other
- places. If we are building with PTH we let pth_init do it. We
- can't do much on error so we ignore them. An error would anyway
- later pop up if one of the socket functions is used. */
-# ifdef HAVE_NPTH
- pth_init ();
-# else
+ places. */
{
WSADATA wsadat;
WSAStartup (0x202, &wsadat);
}
-# endif /*!HAVE_NPTH*/
#endif
#ifdef HAVE_W32CE_SYSTEM