aboutsummaryrefslogtreecommitdiffstats
path: root/common/http.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-08-26 15:47:22 +0000
committerWerner Koch <[email protected]>2014-08-26 15:47:54 +0000
commit519305feb888b529c005b40445d041a088a2f8fc (patch)
tree74994a5b568e059982ca83a0daa8b7d96035355d /common/http.c
parentgpg: Allow for positional parameters in the passphrase prompt. (diff)
downloadgnupg-519305feb888b529c005b40445d041a088a2f8fc.tar.gz
gnupg-519305feb888b529c005b40445d041a088a2f8fc.zip
Switch to the libgpg-error provided estream.
* configure.ac (NEED_GPG_ERROR_VERSION): Reguire 1.14. (GPGRT_ENABLE_ES_MACROS): Define. (estream_INIT): Remove. * m4/estream.m4: Remove. * common/estream-printf.c, common/estream-printf.h: Remove. * common/estream.c, common/estream.h: Remove. * common/init.c (_init_common_subsystems): Call gpgrt initialization.
Diffstat (limited to 'common/http.c')
-rw-r--r--common/http.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/common/http.c b/common/http.c
index 06461dbb7..fe83e3fbc 100644
--- a/common/http.c
+++ b/common/http.c
@@ -1565,7 +1565,7 @@ send_request (http_t hd, const char *httphost, const char *auth,
if (http_proxy && *http_proxy)
{
- request = es_asprintf
+ request = es_bsprintf
("%s %s://%s:%hu%s%s HTTP/1.0\r\n%s%s",
hd->req_type == HTTP_REQ_GET ? "GET" :
hd->req_type == HTTP_REQ_HEAD ? "HEAD" :
@@ -1585,7 +1585,7 @@ send_request (http_t hd, const char *httphost, const char *auth,
else
snprintf (portstr, sizeof portstr, ":%u", port);
- request = es_asprintf
+ request = es_bsprintf
("%s %s%s HTTP/1.0\r\nHost: %s%s\r\n%s",
hd->req_type == HTTP_REQ_GET ? "GET" :
hd->req_type == HTTP_REQ_HEAD ? "HEAD" :