aboutsummaryrefslogtreecommitdiffstats
path: root/common/call-gpg.h
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2015-11-24 12:40:56 +0000
committerJustus Winter <[email protected]>2015-11-25 11:19:50 +0000
commitba1a5cc17d43d9cba32447876f06a8ab8f97e5ae (patch)
treec81fe95c5780376ed1a5ce59eb659915f408eee1 /common/call-gpg.h
parentgpg: When comparing keyids, use the keyid, not the fingerprint's suffix. (diff)
downloadgnupg-ba1a5cc17d43d9cba32447876f06a8ab8f97e5ae.tar.gz
gnupg-ba1a5cc17d43d9cba32447876f06a8ab8f97e5ae.zip
g13: Move 'call-gpg.c' to common.
* common/Makefile.am (common_sources): Add files. * g13/call-gpg.c: Move to 'common' and adapt slightly. Add a parameter to let callees override the gpg program to execute. * g13/call-gpg.h: Likewise. * g13/Makefile.am (g13_SOURCES): Drop files. * g13/create.c (encrypt_keyblob): Hand in the gpg program to execute. * g13/mount.c (decrypt_keyblob): Likewise. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rw-r--r--common/call-gpg.h (renamed from g13/call-gpg.h)9
1 files changed, 7 insertions, 2 deletions
diff --git a/g13/call-gpg.h b/common/call-gpg.h
index 339544d50..606473d88 100644
--- a/g13/call-gpg.h
+++ b/common/call-gpg.h
@@ -20,11 +20,16 @@
#ifndef G13_CALL_GPG_H
#define G13_CALL_GPG_H
-gpg_error_t gpg_encrypt_blob (ctrl_t ctrl,
+#include "strlist.h"
+
+typedef struct server_control_s *ctrl_t;
+
+gpg_error_t gpg_encrypt_blob (ctrl_t ctrl, const char *gpg_program,
const void *plain, size_t plainlen,
strlist_t keys,
void **r_ciph, size_t *r_ciphlen);
-gpg_error_t gpg_decrypt_blob (ctrl_t ctrl, const void *ciph, size_t ciphlen,
+gpg_error_t gpg_decrypt_blob (ctrl_t ctrl, const char *gpg_program,
+ const void *ciph, size_t ciphlen,
void **r_plain, size_t *r_plainlen);