aboutsummaryrefslogtreecommitdiffstats
path: root/common/argparse.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-05-07 16:18:27 +0000
committerWerner Koch <[email protected]>2014-05-08 08:28:23 +0000
commitcb2aeb4e1157fc0d7dc25d94115973422dc1a800 (patch)
treeb99b8a21626090ef1b8647fce922c282d3f3528f /common/argparse.c
parentagent: Fix auth key comment handling. (diff)
downloadgnupg-cb2aeb4e1157fc0d7dc25d94115973422dc1a800.tar.gz
gnupg-cb2aeb4e1157fc0d7dc25d94115973422dc1a800.zip
Make more use of *_NAME macros.
* configure.ac (GPG_DISP_NAME, GPGSM_DISP_NAME): New. (GPG_AGENT_DISP_NAME, SCDAEMON_DISP_NAME): New. (DIRMNGR_DISP_NAME, G13_DISP_NAME): New. (GPGCONF_DISP_NAME): New. (SCDAEMON_SOCK_NAME): New. * common/argparse.c (show_help): Map description string.
Diffstat (limited to '')
-rw-r--r--common/argparse.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/common/argparse.c b/common/argparse.c
index 6d18bd4bc..f4180cfd9 100644
--- a/common/argparse.c
+++ b/common/argparse.c
@@ -1126,7 +1126,7 @@ show_help (ARGPARSE_OPTS *opts, unsigned int flags)
writestrings (0, "Options:", "\n", NULL);
for (i=0; opts[i].short_opt; i++ )
{
- s = _( opts[i].description );
+ s = map_static_macro_string (_( opts[i].description ));
if ( s && *s== '@' && !s[1] ) /* Hide this line. */
continue;
if ( s && *s == '@' ) /* Unindented comment only line. */