aboutsummaryrefslogtreecommitdiffstats
path: root/cipher
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-12-06 20:27:43 +0000
committerDavid Shaw <[email protected]>2005-12-06 20:27:43 +0000
commit8a0cf1d2a342abbcb26dd2cc3397a848123d63fc (patch)
tree68a90779c4fbb4e762d12c1491ee5c8033321030 /cipher
parent* curl-shim.c (curl_easy_perform): Fix build warning (code before (diff)
downloadgnupg-8a0cf1d2a342abbcb26dd2cc3397a848123d63fc.tar.gz
gnupg-8a0cf1d2a342abbcb26dd2cc3397a848123d63fc.zip
* idea-stub.c (load_module): Not legal to return a void * as a function
pointer.
Diffstat (limited to '')
-rw-r--r--cipher/ChangeLog10
-rw-r--r--cipher/idea-stub.c2
-rw-r--r--cipher/rndegd.c5
-rw-r--r--cipher/rndlinux.c5
-rw-r--r--cipher/rndunix.c5
-rw-r--r--cipher/rndw32.c5
6 files changed, 8 insertions, 24 deletions
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index 1efddea8f..23a0c1601 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,8 +1,12 @@
2005-12-06 David Shaw <[email protected]>
- * Makefile.am: Some cleanup so we don't build files that are
- completely ifdeffed out. This causes a warning on Sun's cc. Do
- sha512.c as well for consistency.
+ * idea-stub.c (load_module): Not legal to return a void * as a
+ function pointer.
+
+ * Makefile.am, rndegd.c, rndlinux.c, rndunix.c, rndw32.c: Some
+ cleanup so we don't build files that are completely ifdeffed out.
+ This causes a warning on Sun's cc. Do sha512.c as well for
+ consistency.
2005-08-11 Werner Koch <[email protected]>
diff --git a/cipher/idea-stub.c b/cipher/idea-stub.c
index fc19baeed..55b5cb506 100644
--- a/cipher/idea-stub.c
+++ b/cipher/idea-stub.c
@@ -138,7 +138,7 @@ load_module (const char *name)
if ((err=dlerror()))
goto failure;
- return sym;
+ return (INFO_FNC)sym;
failure:
log_info ("invalid module `%s': %s\n", name?name:"???", err?err:"???");
diff --git a/cipher/rndegd.c b/cipher/rndegd.c
index fb997d283..e6646a243 100644
--- a/cipher/rndegd.c
+++ b/cipher/rndegd.c
@@ -20,9 +20,6 @@
*/
#include <config.h>
-
-#ifdef USE_RNDEGD
-
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
@@ -226,5 +223,3 @@ rndegd_gather_random( void (*add)(const void*, size_t, int), int requester,
return 0; /* success */
}
-
-#endif /*USE_RNDEGD*/
diff --git a/cipher/rndlinux.c b/cipher/rndlinux.c
index ca42eea8a..c6f646c63 100644
--- a/cipher/rndlinux.c
+++ b/cipher/rndlinux.c
@@ -21,9 +21,6 @@
#include <config.h>
-
-#ifdef USE_RNDLINUX
-
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
@@ -161,5 +158,3 @@ _("\n"
return 0; /* success */
}
-
-#endif /*USE_RNDLINUX*/
diff --git a/cipher/rndunix.c b/cipher/rndunix.c
index c3b5cf8e2..3cc71cf0b 100644
--- a/cipher/rndunix.c
+++ b/cipher/rndunix.c
@@ -48,9 +48,6 @@
/* General includes */
#include <config.h>
-
-#ifdef USE_RNDUNIX
-
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
@@ -870,5 +867,3 @@ rndunix_gather_random( void (*add)(const void*, size_t, int), int requester,
return 0;
}
-
-#endif /*USE_RNDUNIX*/
diff --git a/cipher/rndw32.c b/cipher/rndw32.c
index dc3c775c2..f81f1c191 100644
--- a/cipher/rndw32.c
+++ b/cipher/rndw32.c
@@ -61,9 +61,6 @@
*/
#include <config.h>
-
-#ifdef USE_RNDW32
-
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
@@ -700,5 +697,3 @@ rndw32_gather_random_fast( void (*add)(const void*, size_t, int), int requester
return 0;
}
-
-#endif /*USE_RNDW32*/