aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/twofish.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-12-30 00:57:05 +0000
committerDavid Shaw <[email protected]>2003-12-30 00:57:05 +0000
commitd7a28c72a893041f8c8e7b523096601bfdb85fb7 (patch)
tree1ebecbb41d31ec7c6567548a03a25c02e5655b7c /cipher/twofish.c
parent* g10u.c: Dead code. Remove. (diff)
downloadgnupg-d7a28c72a893041f8c8e7b523096601bfdb85fb7.tar.gz
gnupg-d7a28c72a893041f8c8e7b523096601bfdb85fb7.zip
* rijndael.c, rndunix.c, twofish.c: Remove dead IS_MODULE code.
* g10c.c: Dead code. Remove. * Makefile.am: Don't compile g10c.c.
Diffstat (limited to '')
-rw-r--r--cipher/twofish.c73
1 files changed, 1 insertions, 72 deletions
diff --git a/cipher/twofish.c b/cipher/twofish.c
index 554b4aa3e..5026f0305 100644
--- a/cipher/twofish.c
+++ b/cipher/twofish.c
@@ -557,7 +557,6 @@ burn_stack (int bytes)
}
-
/* Perform the key setup. Note that this works only with 128- and 256-bit
* keys, despite the API that looks like it might support other sizes. */
@@ -1010,10 +1009,7 @@ main()
#endif /* TEST */
-#ifdef IS_MODULE
-static
-#endif
- const char *
+const char *
twofish_get_info (int algo, size_t *keylen,
size_t *blocksize, size_t *contextsize,
int (**r_setkey) (void *c, byte *key, unsigned keylen),
@@ -1039,70 +1035,3 @@ twofish_get_info (int algo, size_t *keylen,
return "TWOFISH128";
return NULL;
}
-
-
-#ifdef IS_MODULE
-static
-const char * const gnupgext_version = "TWOFISH ($Revision$)";
-
-static struct {
- int class;
- int version;
- int value;
- void (*func)(void);
-} func_table[] = {
- { 20, 1, 0, (void(*)(void))twofish_get_info },
- { 21, 1, 10 },
- { 21, 1, 102 },
-};
-
-
-
-/****************
- * Enumerate the names of the functions together with information about
- * this function. Set sequence to an integer with a initial value of 0 and
- * do not change it.
- * If what is 0 all kind of functions are returned.
- * Return values: class := class of function:
- * 10 = message digest algorithm info function
- * 11 = integer with available md algorithms
- * 20 = cipher algorithm info function
- * 21 = integer with available cipher algorithms
- * 30 = public key algorithm info function
- * 31 = integer with available pubkey algorithms
- * version = interface version of the function/pointer
- * (currently this is 1 for all functions)
- */
-static void *
-gnupgext_enum_func ( int what, int *sequence, int *class, int *vers )
-{
- void *ret;
- int i = *sequence;
-
- do {
- if ( i >= DIM(func_table) || i < 0 ) {
- return NULL;
- }
- *class = func_table[i].class;
- *vers = func_table[i].version;
- switch( *class ) {
- case 11:
- case 21:
- case 31:
- ret = &func_table[i].value;
- break;
- default:
-#ifndef __riscos__
- ret = func_table[i].func;
-#else /* __riscos__ */
- ret = (void *) func_table[i].func;
-#endif /* __riscos__ */
- break;
- }
- i++;
- } while ( what && what != *class );
-
- *sequence = i;
- return ret;
-}
-#endif