aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/sha512.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
committerDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
commit0f4f660d5fc036af56d20d988bfc23a52dffd158 (patch)
tree4d7e8b764ca7a422c5a847f6b5311344fc9d1aad /cipher/sha512.c
parent* configure.ac: Allow the DNS stuff to work on OSX by trying the (diff)
downloadgnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.tar.gz
gnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.zip
* blowfish.c, md5.c, rmd160.c, sha1.c, sha256.c, sha512.c: Use '#if'
rather than '#ifdef' BIG_ENDIAN_HOST. Harmless as we explicitly define BIG_ENDIAN_HOST to 1 when we need it, but needed for OSX fat builds when we define BIG_ENDIAN_HOST to another macro.
Diffstat (limited to '')
-rw-r--r--cipher/sha512.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/cipher/sha512.c b/cipher/sha512.c
index 523579d25..4b4018941 100644
--- a/cipher/sha512.c
+++ b/cipher/sha512.c
@@ -171,7 +171,7 @@ transform( SHA512_CONTEXT *hd, byte *data )
g = hd->h6;
h = hd->h7;
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
memcpy( w, data, 128 );
#else
{
@@ -332,7 +332,7 @@ sha512_final(SHA512_CONTEXT *hd)
burn_stack (768);
p = hd->buf;
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
#define X(a) do { *(u64*)p = hd->h##a ; p += 8; } while(0)
#else /* little endian */
#define X(a) do { *p++ = hd->h##a >> 56; *p++ = hd->h##a >> 48; \