aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/sha256.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
committerDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
commit0f4f660d5fc036af56d20d988bfc23a52dffd158 (patch)
tree4d7e8b764ca7a422c5a847f6b5311344fc9d1aad /cipher/sha256.c
parent* configure.ac: Allow the DNS stuff to work on OSX by trying the (diff)
downloadgnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.tar.gz
gnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.zip
* blowfish.c, md5.c, rmd160.c, sha1.c, sha256.c, sha512.c: Use '#if'
rather than '#ifdef' BIG_ENDIAN_HOST. Harmless as we explicitly define BIG_ENDIAN_HOST to 1 when we need it, but needed for OSX fat builds when we define BIG_ENDIAN_HOST to another macro.
Diffstat (limited to '')
-rw-r--r--cipher/sha256.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/cipher/sha256.c b/cipher/sha256.c
index 47c754101..7e864cc73 100644
--- a/cipher/sha256.c
+++ b/cipher/sha256.c
@@ -111,7 +111,7 @@ transform( SHA256_CONTEXT *hd, byte *data )
g = hd->h6;
h = hd->h7;
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
memcpy( w, data, 64 );
#else
{
@@ -257,7 +257,7 @@ sha256_final(SHA256_CONTEXT *hd)
burn_stack (328);
p = hd->buf;
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
#define X(a) do { *(u32*)p = hd->h##a ; p += 4; } while(0)
#else /* little endian */
#define X(a) do { *p++ = hd->h##a >> 24; *p++ = hd->h##a >> 16; \