aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/sha1.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
committerDavid Shaw <[email protected]>2006-03-20 00:39:44 +0000
commit0f4f660d5fc036af56d20d988bfc23a52dffd158 (patch)
tree4d7e8b764ca7a422c5a847f6b5311344fc9d1aad /cipher/sha1.c
parent* configure.ac: Allow the DNS stuff to work on OSX by trying the (diff)
downloadgnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.tar.gz
gnupg-0f4f660d5fc036af56d20d988bfc23a52dffd158.zip
* blowfish.c, md5.c, rmd160.c, sha1.c, sha256.c, sha512.c: Use '#if'
rather than '#ifdef' BIG_ENDIAN_HOST. Harmless as we explicitly define BIG_ENDIAN_HOST to 1 when we need it, but needed for OSX fat builds when we define BIG_ENDIAN_HOST to another macro.
Diffstat (limited to 'cipher/sha1.c')
-rw-r--r--cipher/sha1.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/cipher/sha1.c b/cipher/sha1.c
index d150fad1e..63d6325da 100644
--- a/cipher/sha1.c
+++ b/cipher/sha1.c
@@ -91,7 +91,7 @@ transform( SHA1_CONTEXT *hd, byte *data )
d = hd->h3;
e = hd->h4;
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
memcpy( x, data, 64 );
#else
{ int i;
@@ -305,7 +305,7 @@ sha1_final(SHA1_CONTEXT *hd)
burn_stack (88+4*sizeof(void*));
p = hd->buf;
-#ifdef BIG_ENDIAN_HOST
+#if BIG_ENDIAN_HOST
#define X(a) do { *(u32*)p = hd->h##a ; p += 4; } while(0)
#else /* little endian */
#define X(a) do { *p++ = hd->h##a >> 24; *p++ = hd->h##a >> 16; \