aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/md5.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-03-20 16:40:28 +0000
committerDavid Shaw <[email protected]>2006-03-20 16:40:28 +0000
commit70f1c32ffd3f3d00330d394b579ba4f68260c472 (patch)
tree922d2cd91be9fb89fc96d4059246cc95f48294af /cipher/md5.c
parent* configure.ac: Improved --disable-endian-check that doesn't involve (diff)
downloadgnupg-70f1c32ffd3f3d00330d394b579ba4f68260c472.tar.gz
gnupg-70f1c32ffd3f3d00330d394b579ba4f68260c472.zip
* blowfish.c, md5.c, rmd160.c, sha1.c, sha256.c, sha512.c: Revert previous
change. It's now all done in configure.
Diffstat (limited to '')
-rw-r--r--cipher/md5.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/cipher/md5.c b/cipher/md5.c
index f8bd3abb9..270e3fe3e 100644
--- a/cipher/md5.c
+++ b/cipher/md5.c
@@ -100,7 +100,7 @@ transform( MD5_CONTEXT *ctx, byte *data )
u32 D = ctx->D;
u32 *cwp = correct_words;
-#if BIG_ENDIAN_HOST
+#ifdef BIG_ENDIAN_HOST
{ int i;
byte *p2, *p1;
for(i=0, p1=data, p2=(byte*)correct_words; i < 16; i++, p2 += 4 ) {
@@ -311,7 +311,7 @@ md5_final( MD5_CONTEXT *hd )
burn_stack (80+6*sizeof(void*));
p = hd->buf;
-#if BIG_ENDIAN_HOST
+#ifdef BIG_ENDIAN_HOST
#define X(a) do { *p++ = hd-> a ; *p++ = hd-> a >> 8; \
*p++ = hd-> a >> 16; *p++ = hd-> a >> 24; } while(0)
#else /* little endian */