aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/md.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-08-08 19:41:30 +0000
committerDavid Shaw <[email protected]>2002-08-08 19:41:30 +0000
commit3d85ad800d7e4fcd1a3222a07f630e8b89478957 (patch)
tree29814bc2ecc175fc999b77106384501081c996f9 /cipher/md.c
parent* configure.ac: Add an --enable-tiger. (diff)
downloadgnupg-3d85ad800d7e4fcd1a3222a07f630e8b89478957.tar.gz
gnupg-3d85ad800d7e4fcd1a3222a07f630e8b89478957.zip
* Makefile.am, md.c (load_digest_module): Allow switching TIGER on and off
via configure.
Diffstat (limited to 'cipher/md.c')
-rw-r--r--cipher/md.c5
1 files changed, 4 insertions, 1 deletions
diff --git a/cipher/md.c b/cipher/md.c
index 73a2b33cf..34888b9a7 100644
--- a/cipher/md.c
+++ b/cipher/md.c
@@ -95,7 +95,10 @@ load_digest_module (void)
/* We load them in reverse order so that the most
frequently used are the first in the list. */
- new_list_item (DIGEST_ALGO_TIGER, tiger_get_info);
+#ifdef USE_TIGER
+ if (!new_list_item (DIGEST_ALGO_TIGER, tiger_get_info))
+ BUG();
+#endif
if (!new_list_item (DIGEST_ALGO_MD5, md5_get_info))
BUG ();
if (!new_list_item (DIGEST_ALGO_RMD160, rmd160_get_info))