aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/md.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-12 04:51:22 +0000
committerDavid Shaw <[email protected]>2003-02-12 04:51:22 +0000
commitfa9600d2c87d278991e8782742036ea857b930a7 (patch)
treecc7db931ab8817e7b4155f2fd15c65c98ced7427 /cipher/md.c
parent* types.h: Try and use uint64_t for a 64-bit type. (diff)
downloadgnupg-fa9600d2c87d278991e8782742036ea857b930a7.tar.gz
gnupg-fa9600d2c87d278991e8782742036ea857b930a7.zip
* Makefile.am, md.c (load_digest_module): Only build in SHA384/512 and
TIGER if specifically enabled by the 64-bit type check in configure.
Diffstat (limited to '')
-rw-r--r--cipher/md.c4
1 files changed, 4 insertions, 0 deletions
diff --git a/cipher/md.c b/cipher/md.c
index c92390672..1b139568c 100644
--- a/cipher/md.c
+++ b/cipher/md.c
@@ -96,12 +96,16 @@ load_digest_module (void)
/* We load them in reverse order so that the most
frequently used are the first in the list. */
+#ifdef USE_TIGER
if (!new_list_item (DIGEST_ALGO_TIGER, tiger_get_info))
BUG();
+#endif
+#ifdef USE_SHA512
if (!new_list_item (DIGEST_ALGO_SHA512, sha512_get_info))
BUG ();
if (!new_list_item (DIGEST_ALGO_SHA384, sha384_get_info))
BUG ();
+#endif
if (!new_list_item (DIGEST_ALGO_SHA256, sha256_get_info))
BUG ();
if (!new_list_item (DIGEST_ALGO_MD5, md5_get_info))