aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/md.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-09-04 11:53:10 +0000
committerDavid Shaw <[email protected]>2003-09-04 11:53:10 +0000
commit142ef9b0ba7c454838c483f6bab8a007bd38a2c5 (patch)
tree43892a0ef7245e117945a75670a927b0a97d95ec /cipher/md.c
parent* keyedit.c (show_key_with_all_names): Fix assertion failure when using (diff)
downloadgnupg-142ef9b0ba7c454838c483f6bab8a007bd38a2c5.tar.gz
gnupg-142ef9b0ba7c454838c483f6bab8a007bd38a2c5.zip
* md.c (string_to_digest_algo): Enable read-write SHA-256 support.
* algorithms.h, Makefile.am, md.c (load_digest_module, string_to_digest_algo), tiger.c: Drop TIGER/192 support.
Diffstat (limited to '')
-rw-r--r--cipher/md.c13
1 files changed, 1 insertions, 12 deletions
diff --git a/cipher/md.c b/cipher/md.c
index f7ced3a4b..c18a36092 100644
--- a/cipher/md.c
+++ b/cipher/md.c
@@ -96,10 +96,6 @@ load_digest_module (void)
/* We load them in reverse order so that the most
frequently used are the first in the list. */
-#ifdef USE_TIGER192
- if (!new_list_item (DIGEST_ALGO_TIGER, tiger_get_info))
- BUG();
-#endif
#ifdef USE_SHA512
if (!new_list_item (DIGEST_ALGO_SHA512, sha512_get_info))
BUG ();
@@ -135,8 +131,7 @@ string_to_digest_algo( const char *string )
understand the hashes before we release one that generates
them. - dshaw */
- if(!ascii_strcasecmp("sha256",string)
- || !ascii_strcasecmp("sha384",string)
+ if(!ascii_strcasecmp("sha384",string)
|| !ascii_strcasecmp("sha512",string))
{
log_info(_("digest algorithm `%s' is read-only in this release\n"),
@@ -144,12 +139,6 @@ string_to_digest_algo( const char *string )
return 0;
}
-#ifdef USE_TIGER192
- if(!ascii_strcasecmp("tiger192",string))
- log_info(_("WARNING: digest `%s' is not part of OpenPGP. "
- "Use at your own risk!\n"),string);
-#endif
-
do {
for(r = digest_list; r; r = r->next )
if( !ascii_strcasecmp( r->name, string ) )