aboutsummaryrefslogtreecommitdiffstats
path: root/cipher/g10c.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-12-30 00:57:05 +0000
committerDavid Shaw <[email protected]>2003-12-30 00:57:05 +0000
commitd7a28c72a893041f8c8e7b523096601bfdb85fb7 (patch)
tree1ebecbb41d31ec7c6567548a03a25c02e5655b7c /cipher/g10c.c
parent* g10u.c: Dead code. Remove. (diff)
downloadgnupg-d7a28c72a893041f8c8e7b523096601bfdb85fb7.tar.gz
gnupg-d7a28c72a893041f8c8e7b523096601bfdb85fb7.zip
* rijndael.c, rndunix.c, twofish.c: Remove dead IS_MODULE code.
* g10c.c: Dead code. Remove. * Makefile.am: Don't compile g10c.c.
Diffstat (limited to '')
-rw-r--r--cipher/g10c.c46
1 files changed, 0 insertions, 46 deletions
diff --git a/cipher/g10c.c b/cipher/g10c.c
deleted file mode 100644
index 7b0f4fa61..000000000
--- a/cipher/g10c.c
+++ /dev/null
@@ -1,46 +0,0 @@
-/* g10c.c - Wrapper for cipher functions
- * Copyright (C) 1998, 1999 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-#include <config.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include "mpi.h"
-#include "random.h"
-#include "cipher.h"
-
-
-/* FIXME: The modules should use functions from libgcrypt */
-
-
-const char *g10c_revision_string(int dummy) { return "$Revision$"; }
-
-MPI
-g10c_generate_secret_prime( unsigned nbits )
-{
- return generate_secret_prime( nbits );
-}
-
-
-char *
-g10c_get_random_bits( unsigned nbits, int level, int secure )
-{
- return (char*)get_random_bits( nbits, level, secure );
-}
-